After 40 second reset, I have not able to access the EX2Ultra except by logging in

After a 40 second reset, I went back to the basic WD instructions for mapping the EXUltra2, but I can no longer access the public share from either Windows 10 Pro or Home.

Interestingly, though my android can access the drive via a utility called CxFileExplorer.

Any suggestions would be welcome.

Thanks
George

I went back and checked the following windows settings:

  1. Open the Local Group Policy Editor (gpedit.msc).
  2. In the console tree, select Computer Configuration > Administrative Templates > Network > Lanman Workstation .
  3. For the setting, right-click Enable insecure guest logons and select Edit .
  4. Select Enabled and select OK .

Then I started the WD instructions

How To Map a WD Network Drive on Windows 10
Map Drive by Device Name
image

This is what happens when I try the name in windows explorer


This is what happens when I try the IP address in windows explorer

I end up logging into the device instead of getting network Public share access

Here is network configuration on the EX2Ultra:



image

The documentation for shares holds a description for “Accessing the Contents of a Share Locally” which seams to be outdated.

As stated in the specs, using my win10 I open the file explorer on “This PC”,
then open “Computer > Map Network Drive”,
then type “\\nameOfNAS” into the field named “Folder”,
then click “Browse…”.

This is the result when I try that:

PROBLEM FIXED BY USING THE FOLLOWING:

Please have a look onto the texts within that picture!

The last letters within the field named “Folder” are “EXTRA”, not “ULTRA”, and the “\\” at the beginning is missing. But the letters within the error message correctly show “\\…ULTRA”.

What happened there?

If my memory is accurate, that was a name that windows seemed to come up with during browsing. This doesn’t make any sense since the list under the Network doesn’t show that name but the map with a hard IP address seems to be working, so that is what I went with.

I have no clue why mapping doesn’t work, since you can see the systems mounted on the PC:

Do you have turned on:
Settings → Network & Internet
→ Advanced Network Settings → Network and Sharing Center
→ Advanced Sharing Settings
→ Private → Network Discovery

as well as the automatic setup of connected devices?

Yes

Although the primary goal is achieved, I would still assume a wrong configuration, a malfunction or an infection somewhere in the network, including a kidnapped router. This because both data boxes seam to be not in the network in which the PC is… and the fishy characters in the field named “Folder”.

Two thoughts,

First is did I fat finger the NAS name in my dozens and dozens of attempts to get this working or do I have a “kidnapped router”.

Secondly is that I have a “kidnapped router”.

All computers and phones are running Bitdefender “total security”.

I have a Verizon Actiontec M1424WR router running WPA2. I could further protect myself by preventing SSID broadcasting and use MAC authentication, but I thought this was overkill.

How can I further analyze my risks?

Thanks

  1. “fat finger”
    By only clicking on the “Browse” button, i.e. with no characters in the field named “Folder”, my NAS shows up after some seconds. Therefore your “fat finger” seams to be true, but the problem stays, that your data-boxes do not show up.

  2. Router
    An old report on your type of router: https://nvd.nist.gov/vuln/detail/CVE-2013-3097.

Interestingly enough, when I decided to add my wife’s machine, an MS Surface windows 10 pro, it did NOT require any credential authentication to become visible.

Reliable indication of a malfunction of your own machine or your own installation of Windows 10 Pro.

Edit: @NAS_user has just given a hint for one of the many possible malconfigurations.