EX2 Ultra - have tried EVERYTHING but not visible on Windows 10

Hi all,

I am still unable to see my files using a traditional “Folder” using Windows 10, therefore unable to easily access files and click and drag from laptop to EX2 Ultra to cloud storage etc.

here is a history and steps taken thus far:

I once had access to my EX2 Ultra but then in January 2020 I needed to reload all my software on Windows 10 Surfacebook due to a problem with Outlook Exchange. Since then, I cannot access my files through “File Explorer”. So, here is where I’m stuck!

  1. I can see the “MyCloudEX2Ultra” under “Network” and “Storage”
    When I double click on “Storage” it takes me to the web browser where I can log in as Admin. Everything looks ok here (although, I haven’t played with my settings on the EX2 Ultra).

  2. I have loaded the My Cloud App on Galaxy 10 and have full access to my files via this app.

  3. I can log in with my username and password via web browser and access all my files on the NAS.

  4. I have tried these guides (I can only add 2 links as I’m a new user):

“EX2 Ultra only shows web page, not public directory”
(from the WD Community page)

“How to Map a WD Network Drive on Windows 10”
(from the WD community page)

“FIX NAS Drive not visible on Network Windows 10”

“Ex2 ultra shows up in Win 10 as Storage, not as computer”
(from the WD community page)

and this

https://support-en.wd.com/app/answers/detail/a_id/9323#win7

When Mapping Network drive, even though showing up in Network as “Storage”, when I type int he IP address, I receive the error “Windows cannot access \xxx.xx.x.xx”

So, I have changed the TCP and SMB checkboxes and reset my computer, nothing, I have mapped drive, but windows cannot find it.

  1. I have installed WD Discovery - no good for Ex2 Ultra

  2. I have installed GoodSync and I thought this is promising. But… I can see the “MyCloudEx2Ultra 2-Bay NAS” but when I select it, I am greeted with the error:

  3. I have rebooted the Ex2 Ultra multiple times, but still no connection via the File Explorer.

  4. I have NOT totally disconnected the EX2 Ultra from my network as I worried I will lose files (I’m not in IT, but can usually find fixes for my business myself… but worried I will do something that will make me lose all my files… the whole purpose I bought the EX2 Ultra!!!).

“! The network path was not found. (error 53)”

I can see this issue has been blogged to death, however if someone has any additional settings or steps I should take, please please please advise.

ADee

Hi there,
not sure this will work for you… but I have recurrent problems connecting to the drive when trying to use it in the native windows explorer file system.
The best way I find is mapping it as a network storage. Using \ipaddress\sharefolder or you can also use the hostname of the NAS. when you do so, it will ask you to authenticate and here is where I have recurrent problems.
The users I have setup on the NAS system do not seem to work consistently. Nevertheless the way I find it working often is to use the following (whenever the “windows credentials” window comes up.
windowsAccount\username.

Thanks! I will look into your solution during the week and report back… I’m little frustrated with WD and Windows… this appears to be a long term problem for many and wish both parties would work together to find a fix. Anyway, enough of my whinging :slight_smile: Lets hope your advice works when I try it out during the week. Many thanks for your reply.

1 Like

The problem relates to SMB protocols that WD’s Linux-based NAS boxes use to communicate.

I have long had problems with File Explorer not showing the NAS as a “computer” in file explorer. You are correct in that if it shows up as storage. . . that won’t get you access to files.

There are numerous threads on the topic. None of it works long term. Sure, I routinely get the stupid NAS to show up. . . .but rarely on the first try. BTW: I have this issue with four different WD Linux based products.

Frankly. . . I access the NAS by using the Windows File Explorer and typing the ipaddress (\192.168.0.xxx) or the unit’s “Friendly name” (\MyNas) directly in the explorer address bar. Works without fail.

I believe if you omit the double slashes; you get the Web interface.

This is a windows 10 issue. No-one has really found the solution yet. In the meanwhile, go to explorer and “map network drive”.

Did you try enabling insecure guest logons? I had the same issue and that did the trick for me.
Open the Local Group Policy Editor
Navigate to: Computer Configuration > Administrative Templates > Network > Lanman Workstation
Double-click on “Enable insecure guest logons”
Change the value to “Enabled” (mine was “Not Configured”).

Hope it helps.

I was also able to make it work by adding Window Credentials.

Go to: Control Panel > User Accounts > Credential Manager
Click on Windows Credentials
Click on Add a Windows Credential
In the network address field, enter your server name without the “\\” (for me “mycloudex2ultra”), then User name and Password and click “Ok”.

Note that if you want/have to access your server by IP address instead of name, you need to enter the IP address instead of the name. If you want to do both, you need to 2 credential entries.

That should do the trick as well. If you setup the Windows credentials, you should be able to revert the “Enable insecure guest logons” value to “Default”.

Good luck.

1 Like

ok peeps, I’ve got some fantastic news. I now have access thanks to a local IT company that came to the rescue.

Unfortunately, I don’t have an exact solution. When I asked what was the solutions, he said he wasn’t exactly sure what cured the issue, as he had tried many possible fixes. He has seen this thread so might respond himself (I havent entered name of person or comany just in case I’m not allowed to on this page or he doesnt want his name in lights, but I can say I’m very happy with the result).

From what I understand, there were a few steps taken and a few anomallies with my network. Remember, I dont know all the steps, but this is what I do recall:

  1. tried creating new accounts on the Ex2Ultra - no good.
  2. uninstalled Trend-Micro and firewall - still no access.
  3. disabled windows defender firewall - still no access.
  4. The path was: EX2 Ultra cat5e to ASUS3100 router, then cat5e to surfacebook docking station.
    Discovered that the IP address for the Ex2 via the ASUS router didnt look right. Fixed that: still no access.
  5. Played around with a few more settings via the DOS looking window - still no access.
  6. I believe tried insecure log-ins, but no good.
  7. Recycled the power on a few items - still no access
  8. Plugged his lenovo W10 machine into the EX2ultra - he had access.
  9. Replaced ethernet from Ex2Ultra in to his Lenovo to look for harddrive from my W10 machine - could not discover his hard drive.
  10. I think he then tried to go directly from my W10 machine to a drive he had - still no access.

At this point, very confident that it was a setting on my machine and not the Ex2Ultra via the Asus 3100 router.

  1. Tried a few more things, no good. We spoke about SMB and he said that wasnt SMB. (I have checked the windows credential I added last night, but they have either disappeared or were removed as there is no indication that I can see of the 2x windows credentials I created or any new ones).

  2. Some more playing around and rebooting, finally success! I now have a new IP address for the Ex2Ultra and have mapped the drive so I can see it next to my C:.

When I asked what fixed it, he said not sure exaclty, but found a thread somewhere else that he followed which was the last thing he tried:

So, a big thank you to everyone for your interest and assistance, and a big thank you to A who dropped in this afternoon to fix the issue!

This post was flagged by the community and is temporarily hidden.

I’ve found both the MyCloud ext2 and MyCloud ex2 ultra to be a bit of a disappointment as well. I bought them to replace my Dlink 323’s. The 323’s show up fine on windows 10, Mac and Kodi media player on a raspberry pi. The WD NAS’s show up fine on my mac but not on Windows 10 or Kodi media player. I went through the first suggestions for windows 10 post 2018 creators update. Today I am going to get serious and not give up until I get the WD’s working on all 3 platforms.

In the PC world. . . making the WD devices show up correctly under “Network” in the file explorer just doesn’t seem to work. That’s with four different products; although admittedly the firmware is very similar between the models.

Mapping the drive is successful for most.
For me. . . I set an easy to remember device name (like. . .“BOB”) and I can access the drive easily from any file explorer address bar (i.e. type “\Bob\taxes” (two forward slashes) to access the tax folder on the drive

Thanks for this. I was wondering why some of the settings in the device webpage settings were unlabelled. Called into the help line and they told me which one was NFS enable. Once I enabled it my Kodi media player found it and I was able to map it as a drive letter onto Windows10. Not sure what’s with the settings labels not showing. I tried later and they showed. Gotta to be a browser thing I’ll need to get to the bottom of.

I’ve had similar problems in the past and found it is usually one of the following (or both in combination):

Network Settings (on WD EX2 or EX2 Ultra NAS)

  • Login as an admin (or equivalent) to the My Cloud dashboard using a web browser.
  • Go to the Settings tab.
  • Select Network from the side column.
  • Check that the IPv4 DNS Server address matches your router (e.g. 192.168.0.1). This assumes you have your router setup as the DNS server for your LAN.
  • If the DNS Server address is not the same as your router, then what happens is that Windows File Explorer (via your router) will not be able to recognize \\mycloudex2ultra (or whatever name you’ve given your NAS). DNS translates the name to IP, so if the DNS server info is incorrect on the NAS, then Windows/router cannot find it by name. Even when the DNS server is not configured correctly, you still might be able to provide your LAN IP address in Windows File Explorer (e.g. \\192.168.0.20 or whatever you NAS IP is assigned) and be able to navigate NAS folders.
  • To fix the DNS server on the NAS, one option is to change the IPv4 Network Mode to Static and then enter the fixed IP address information including the correct DNS server that matches your router IP.
  • If this information all aligns, then you should be able to use Windows File Explorer and enter \\mycloudex2ultra (or whatever you NAS is named) in the network path field and be able to navigate the NAS folders both private (with credentials entered in Windows) and public.

Credentials (on Windows 10)

  • Open up a Control Panel in Windows using an admin (or equivalent) account.
  • Go to the User Accounts (and again User Accounts underneath that)
  • At the screen to “Make changes to your user account”, select “Manage your credentials” from the side.
  • Click on Windows Credentials.
  • Usually at the top of the list you will see credentials you’ve previously saved for network devices like a MyCloud EX2 or EX2 Ultra. These will possibly be saved as past or current names or IP addresses.
  • See if there are old/stale NAS related entries and consider (using your best discretion) removing anything that shouldn’t be there anymore. Alternatively, you can edit user names and passwords for valid network addresses using the “Edit” option under each entry.
  • If you remove your old NAS entries and then go back to File Explorer, you will get a fresh pop-up when trying to access the NAS network location (e.g. \\mycloudex2ultra) and if checkbox is selected it will be saved anew in the Windows Credentials.
  • If you had old user names or passwords (or confusing/conflicting network entries) in your Windows Credentials, this is a method I found to clean it all up with respect to NAS credential access.

Hello all. I have an EX2 Ultra with OS 5, connected to a LAN with Win10 and Win7 computers. The Win10 machines work fine with it, using the default/off-the-box settings. However, the old Win7 computer struggles with discovering the EX2 on the Network Neighborhood. Typically the name shows up, but clicking on it brings up an error pop-up of the sort “Can’t connect to or <internal_IP>”. Other times the EX2 shows up as “Storage” (not as “Computer”).

So, what worked in my case: Go to EX2 ultra via browser interface > Settings > Network > Windows Services > SMB protocol > Set this to [SMB 1, 2 and 3]. This applies immediately, and I can see my device and files in Network>Computer, after giving credentials (one-time).

However, I noticed that it sometimes defaults back to [SMB 3] (only), so I occasionally have to switch it back… I’ve also mapped some EX2-folders as network drives (on Win7), but they too get disconnected when the EX2 is reverted to [SMB 3]. Resetting this to [SMB 1,2,3] and logging in, re-connects my network drives.

Hope it helps.

@Aleonymous
Can you please contact support and provide your My Cloud system logs?
We’re interested in understanding how “Samba Protocol” reverts back to SMB without user interaction?
Please put [OS 5 SMB Reverts to SMB3] as the case subject

Do you use win 10 if so in file explorer go to my pc at the top you you see map a drive find public folder on ultra and the map it it will also give you a drive letter

I too spent hours and hours trying to access my EX2 Ultra from Windows 10 (which used to work), tried all the suggestions. I eventually found that I had set incorrect DNS server IP addresses (well, they were valid, but then I moved the drive to a new location and ISP, where those DNS server IP addresses were not valid).

Once I set valid DNS server addresses in the EX2 Ultra the Windows shortcut to \DeviceName\Public immediately worked.

This is what did it for me. Recently acquired a Windows 10 Enterprise machine from a local Goodwill which I know differs from home and pro versions of windows 10. Manually adding in the credentials allowed me to access the main share of the mycloudex2ultra.

1 Like