MyCloudEx2Ultra works fine on one PC, not on the other. I tried all!

MyCloudEx2Ultra works fine on one PC, not on the other.
Both PC’s are Windows 10, 64 bit,
both PC’s, can access the drive through browser, no problem.
Problem is on One PC, I cannt access through Explorer, on the other, it works fine.

My conclusion:

  • Network and cabeling is OK!
  • The MyCloudEx2Ultra, is setup correctly, I assume (One PC working 100%)
  • The MyCloudEx2Ultra is on both PC’s, in Device Manager registred as Software Devices!
  • Which Setting on the other PC, is the problem?
    NB!! I even reinstalled Windows 10, without solving the problem!

Which setting, did I not mention ?

Regards
Sønder

Hi Sonder,

Please follow the instructions given in the link mentioned below and check if the issue persist.

Thank you so much for your support,

It is much appreciated.

I attach a screen shot, as you can see, the SMB was on,

There was nothing to change,

And the device, MYCLOUDEX2ULTRA, is there, as Storage and as Computer.

When I double click computer, I still, cannot get in, I get the dialog, shown

Windows cannot access …

When I click the storage, the browser opens,

and I can access the device, no problem, with login and password,

but I cannot open in my Explorer.

Like I wrote earlier, latest firmware and latest Windows updated.

What the h… I am doing wrong ?

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Hi Sonder,

You should try to perform 4 second reset on the drive and check is the issue still persist.

Please refer to the link given below for more information.

Thank you for fast answer Alex,

Really appreciated.

I have reset, as you said, and tried map a network drive, no luck! Sorry

I continuously get the message, which was in the center of the last screen shot.

Does this say you somethings ?

NB! My e-mail is sometimes with start capitals, sometimes, with only small letter.

Could a simple thing like this, be the problem ?

Still, the worst, I have one IDENTICAL PC working, on the same drive, with the same login, but this one cannot!

Is there a way, I can send you all my settings, and they are useful for you?

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Hi Sonder,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

Hi Alex,

Thanks, your help is very appreciated,

STILL, this drive, drives me mad!

Yes, I have done a full reset, all users and shares gone,

  •    After reset, I have created two users again.
    

(SAME name as last time.)

  •    The Internet Explorer access works super!
    
  •    After “That is’it”, I have a page with 3 links, if I push any, I get error 404 (attached)
    
  •    If I push the link in explorer, I still get “Windows_cannot_access_error-80070035”.  (attached)
    

So, no progress, all still the same!

And still, MY OTHER SIMULAR WINDOWS 10 – 64BIT COMPUTER, with the same login, works fine!

It just drives me mad!!

Do you have a similar easy list of links to do, TO RESET ALL THE WD SOFTWARE AND RELATED SETTINGS IN MY PC ???

Some PC software or PC setting, must be different.

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Hi Sonder,

You should refer to the link given below for more instruction in order to troubleshoot the issue.

Thanks Alex,

I have checked all this twice, and I feel, there are nothing which is not as you say, it should be.

However a few settings are different from what you show, I try add some screen cuttings.

I am so sorry, I have been through this so many times now.

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Hi Alex,

I am working on this, this weekend, and I have continued, now Monday, until I get it fixed.

This week, I used 60 hours, to try to get it fixed.

It is so embarrassing, We have three computers and an MyCloudEX2ULTRA,

All works fine, on two computers, but NOT ON MINE!

Third computer is MAC, it works fine, so let us keep this one out.

The remaining two, are both Windows 10 Pro update level 1803,

One (Vaio) works super, but mine (a DELL with docking) do not!

The second computer runs wireless,

Mine, runs through a DELL docking station, through a cabled network, but all to the same NAS.

I have naturally also tried mine through both cable and wireless.

  •     First I change language and region, as if I was in the UK English.
    

I have earlier and currently seen problems with language.

But also easier to follow your web references.

  •     Then I go through the points in: How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
    
  •     Point 1: My Cloud, My Cloud Home, or My Passport Wireless products are not detected under Windows 10 Network.
    

This not the problem, but we take, step by step.

o Windows 10 Pro version 1803

o I still open Windows Features, and I ONLY HAVE TWO SUB FEATURES, not 3 like you, but they are set.

I do not have Automatic removal, but below, I have SMB direct, WHICH IS ALSO SET ??

o This is the same on both computers, working or not!

  •     I find no problem in this link!
    
  •      I go through the “How to Enable Windows Network Discovery”, all, on both computers are “Turn on network discovery”, and Files&printer sharing,  both Home and public.   And on all NetWorks, I have “Turn on sharing so that anyone with  …..”
    

o I have naturally tried, on both Network connections.

  •     On “Enabling NetBios Over TCP in Windows”, I have checked the “Enable NetBios over TCP/ip”, and it is set.
    

On the Second PC, the one working, it was “Default”, on the one not working, it was enabled.

  •     Then I check and compare the services.msc, looks alike, and I naturally specially check that all in running and set to Automatic.
    

o I noticed, that the UPnP Device host id NOT running, on the second PC working, but it is on, on my PC, which is not working!

o All others are running and set to Automatic.

  •     My “My Cloud Max SMB Protocol”, is set to SMB 3.
    
  •     I do the points on”
    

Power Cycle Network Equipment”, still no change.

o I am down to the last point on your list, Try to install SmartWare on an other computer on the same NetWork,

So I try install on mine, and check again, SmartWare works fine!

o I just cannot see the NAS in Explorer on this PC, but from all other!!

  •     I try “Data Lifeguard Diagnostic”, and “WD drive utility”, either of them, find the NAS?
    

Probably normal.

  •     I can no problem, from both computers, see the files on my same user, on the other computer, after login and password is given.
    
  •     One thing, that start to worry me, is that now the system says, my connection is UNSAFE;  what did I do wrong!!
    

I am sorry to be to so much trouble, I really try to solve.

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Hi Sonder,

Please check your private message.

Hi Alex,

Thank you again, for your support!!

GOOD NEWS!!! As I wrote, I would bring my NAS to another office, as I am traveling this week.

And, here at the other office, I think, I have seen my problem, and that I can fix it, when I get home!

But please hold support, until next week, I will test in the weekend.

In the meantime, one more request, to make me feel safe with my WD NAS.

My NAS, is supposed to “ONLY BE USED INHOUSE!!”,

  •    No external connection, outside the office router, please!
    

None, what so ever, the NAS should be only internal in office.

  •    NO FTP, or other.
    
  •    Only:
    

o Backup of local computer, works good with your software.

o And shared disk area, for common projects!

Where the 3 local PC’s share their data.

Accessed by normal Explorer.

Can I find a link, a help, where I can see, which settings, best secure this?

Thank you again, for your support, it is appreciated.

Med venlig hilsen / Best Regards

Jørgen Sønder CAM ApS

Mobile +45 40 60 32 96

Try going directly into the drive’s directory so Windows discovers it.
\\MYCLOUDEX2ULTRA\Public
Hopefully this fixes the problem if the drive isn’t getting discovered.