Loosing Connection

Since the 2.10.310 firmware update the NAS has been loosing connection to my network about every 1 to 72 hours. On average it looses connection about every 16 to 24 hours. This has been horrible. Nothing like being out of the house and vitally needing a file on the drive… that has lost connection.

Is there a way to downgrade back to the last update?

Any help would be much appreciated.

Hi TJAC_1,

if you already tried to reset the EX2 (just a try), you should can downgrade the FW following the info here (thanks to AxelXbc) :

Where to find the old firmware and installation instructions

The issue here is that you have to find (if don’t have it) an older FW somewhere !
Good luck .

Thank you Paulus for the link. If no other suggestions on how to fix this can be found, I will investigate this option further.

I’m hoping to resolve the issue without need of going backwards. LoL!

TJAC_1 Hello. Please tell me a few words about how you fix your problem? I have the same problem right now. I bought MyCloud EX2 10 days ago and I can’t work with it at my home net.

I didn’t fix my problem. My EX2 regularly looses connection to my network about ever 8 to 24 hours. My solutions I’ve tried besides factory reset have not worked. I can’t find an older copy of the firmware to try a roll back. I would attempt the factory reset, but I don’t want to loose over a year of data at 3T+.

I’m just saving my pennies for a better NAS, and once purchased will move everything to that. I’ll then factory reset this unit.

If WD would just fix the problem… obviously it is an issue, I see the problem in mass when I try to Google for a solution. Kinda pisses me off, they take our money, and don’t seem to care after that. I’ve been a loyal WD HDD buyer for 20 years now. To bad their NAS doesn’t live up to the standard of their drives.

Try setting the EX2 link speed from Auto to manual (either 100 or 1000) and see if that helps.

Setting it to 1000 didnt work. I’ve set it to 100 now. I’ll let you know in a couple days. I also set IPv4 to Static, before and after setting it to 1000. It didn’t help. I’ll do 100 at both as well.

This did not work.

If anything my problem has gotten progressively worse. The device will not stay online more than 6 hours now.

Anyone got an idea???

Have you tried restarting your router?
After all the issues may be with another component of your home network.

It may also be worth assigning a fixed IP address in your router (so the IP address for the EX2 never changes) just for elimination purposes.