Where to find the old firmware and installation instructions

I can’t deal with the latest firmware as it has killed all my NAS to USB backups.  Is there someplace I can get the old firmware and any special instructions on installing it?  I know with the My Cloud I had to “trick” the system into thinking the old firmware was an upgrade.

Thanks

You can get it from here

http://www.wdc.com/wdproducts/updates/?family=wdfmycloud_ex2

Save it to your desktop and extract the Zip file. You will be left with a .Bin file that you DO NOT RENAME.

Under Settings (All the way to the right). Select “Firmware Update” at the bottom left. Then under “Manual Update” select “Update From File”. Browse to the file then click update. Allow it to update for at least 10-20 minutes.

“”"“WARNING”"""" I recently downgraded to this Firmware as well, but in doing so I was not able to login to my Main menu interface (UI). To Fix this I removed both of my hard drives (To ensure files were not harmed) and did a reset on my WD EX2. I heald in the reset for around 40 seconds or so.

1 Like

I just visited that page, looking for older firmware to support a possible downgrade for my WDMyCloudEX2 to restore full Web File Viewer functionality. Unfortunately, the site is only offering me the current firmware (2.10.310) and none of the previous versions.

Is there an archive here somewhere for older firmware?

I have it on my Google Drive, but don’t want to post the link for all to see. However, I have never been able to get the bin file to work as a downgrade. I keep getting error messages and Level 2 support won’t help. Been waiting for a few weeks…

I found the file on WD’s site… that is, assuming that the following is the correct version:
http://download.wdc.com/nas/My_Cloud_KC2A_1.05.36.bin.zip

Is this the one you’ve been attempting to install?

Yes, that’s the one.

Not sure if this will work…because I am not sure what error messages Stealth57 got, but try renaming the zip-extracted file to “WD-NAS-firmware” (without quotes and no filename extension - just what’s inside the quotes). Then do the manual firmware update as outlined by AxelXbc above.

But I do not know what are the side-effects of downgrading to this old firmware from the current one. That’s a risk only you can decide whether to undertake or not.

After the manual update gets done with the “download” portion, the error message simply says “Upload firmware failed. Try again.”

Update: tried the renaming suggestion and get the same error message.

You should unzip the bin file before installing.
Don’t rename it.

Yes, it was unzipped in both scenarios…

For me it works (unzipped of course) but with that filename that I mentioned. I had not upgraded to the 2.x firmware though.

Try to restart the device before performing an update.
I’ve already 3 times updated to 2.10.302 and then downgraded to 1.05.36. May be they blocked this ability in .310 version.

Ejected the attached My Book, removed USB cable, rebooted EX2100…same error message. Downloading the file again just in case it is corrupted.

UPDATE: New file gave same error.

EX2 and EX2100 are different models! I don’t think that firmware for EX2 can be installed on EX2100.

OK, I never posted which EX device I was using in my OP. I guess I should have or someone should have asked before directing me to a download page. I have now found one that specifically says EX2100. But not on the WD site.

1 Like

Sigh…this is the EX2 sub-forum. If you post anything here, it is assumed you are talking about EX2 and not EX2100. That is why no one asked you about it. When you go to the main community page (community.wd.com), you see everything split into sub-forums. The first-gen products, EX2 and EX4 have their separate sub-forums. EX2100 and EX4100 got their own joint sub-forum titled My Cloud Expert Series. It is here -> https://community.wd.com/c/network-attached-storage/my-cloud-expert-series

And obviously, EX2’s firmware will not work on EX2100.

Thanks. Now I have to figure out why after downgrading to My_Cloud_EX2100_1.06.133.bin the firmware recognizes my password, says I’m the admin, but won’t let me make any changes (like adding back my Cloud devices). I think a hard reset in the morning will be a good place to start.