MyCloud EX2 Ultra (12TB, Raid 0) - Dropping network connectivity

I recently purchased a MyCloud Ex2 Ultra (12TB, Raid 0), installed it on my network, checked for firmware update. Installed software on my Windows 10 workstation, IPAD Pro (2017), IPhone 6S and transferred all of my media (photo’s, documents, video’s, music).

Everything worked perfectly for the first month, then the new firmware update was automatically installed and I began to have problems.

  1. Within 24 hours of a reboot the device, as the hours progressed became slower and slower until - according to the network is “unavailable, only local documents are available”. A second reboot would correct the situation. (there are 3 solid blue lights on the front of the device).

  2. I ran the check disk and the drives have no issue.

  3. I phoned WD support 3 times - each time the person blamed my internet service provider and wanted to hang up after being informed that there was 3 solid blue lights on the front of the device.

  4. The last technician I would not let go, he connected onto my device and took a look at it. Could not explain why it was occurring and then told me it should be replaced.

So I now have my replacement drive - still in it’s box. I am going to call them (WD) and schedule a setup time. However I am not convinced or satisfied that it was a device issue… it only started happening after the latest firmware update.

Anyone had the same issue ? Was there any fix ? I am running it from an ASUS router, hardwired to it. At the times the device is not available are the times I am at work when nothing is being used…

Good luck to you with WD Support. I’ve had good, bad and just plain ugly from them, like Gumps box of chocolate-ya never know!!!
I too am a EX2 owner for 4 years now, got one of the first boxes out. Had USB problems with a confusing trail of effects but no defined causes. Example: have an older MyBook 1TB USB2.0 external. For the first few months after connecting it I could browse it, read and write large files to it with no grief. Then suddenly (firmware upgrade, new Netgear router, little linus server board starting to go south or some other ideosyncratic unknown cause) the 1TB MyCloud disappeared off my LAN. When through multiple soft and hard resets, complete factory reset via the magic pin hole etc. Followed every posted ‘fix’ there was on the net, nothing worked. I eventually gave up on having that USB drive as an extension of the EX2, made it a share on my Win 7 tower and bought a new 4TB MyBook USB3.0. Wow, plugged it and it’s instantly recognized and works like a charm off the EX2. This new USB3.0 drive stayed that way for almost 1 year. So what’s the diffence? The old 1TB USB2.0 drive passed all the WD tests, works great on a PC USB port.
Well this joy all went south last month when suddenly that 4TB drive also started disappearing. At first suspected it didn’t like all the added capacity I’d thrown on it. When I first attached it last year it was less than 10% full. Now it’s about 30% full so its it re-indexing, doing a lot more network ACK-NAK traffic because its getting fuller. Went through all the time sucking multiple hard and soft resets trying to diagnose it. I notice that if I leave the 4TB plugged into either USB port reboot the box it never is recognized. However if I plugg it in AFTER the EX2 has rebooted it is recognized and continues to be recognized but only for about 15 minutes. Then suddenly, boom, its gone from Window Network and my LAN. At that stage I can still ping the last known IP (I’m still letting my router DHCP it) but cannot access the dashboard from Chrome or Firefox which makes sense since its not on the LAN at that point. So what causes box to stop handshaking with the Windows network after 15 minutes of being plugged in? I think I’m on the way to ordering a Synology or QNAS or some other NAS because it appears that aside from a lot of suggestions about logging into execute SSH commands and turning off various default functions (of which I tried a few to no avail) there really is NO solution to this USB problem. BTW the two 2TB WD Reds inside configured as JBOD have never given me grief and their are 80% full now…(tapping on my magic bit wand for good luck).

OK one more kick at the bit bucket–
Just attached my wife’s spare 2TB WD Passport (USB powered). So far EX2 is stable and is NOT losing itself on my LAN.
Duh, so what happened to my 4TB WD MyBook external that it seems to caues the EX2 to become unstable.
WD if you are ever listening please tell me.
And don’t tell me to reformat the 4TB (that was a previous ‘suggestion’ by WD support). It’s just a NTFS formatted USB3.0 which shows NO errors when scanned and is not fragmented!