Login credentials for new users (MyCloud 1st Gen, v04.05.00-342)

Hello,

After a successful Quick Restore & then a restore from a Safepoint my device seems to be working normally.

I can login (browser) as admin with newly-set-up credentials.

However, when I re-create a user (with a password & passwords “on”) I can’t similarly login as that user - the login is rejected as having the wrong password, even though I’m getting the password right. (Same happens for a 2nd, 3rd new user etc.)

Any ideas?

–N.

(PS: PC is running Win 10; browser is Firefox. Plus I’ve tried emptying Credential Manager of device logins.)

(PPS: Each new user has a MyCloud.com account.)

(PPPS: Doesn’t work from Win 7 either; also doesn’t work from Internet Explorer as well as not from Firefox - both tested on Win 7 & Win 10.)

What is the specific error message you receive?

Is remote access/cloud access feature enabled via the My Cloud Dashboard > Settings section? And if so what does it indicate for it’s connection status?

“The user name or password is incorrect. Try entering it again.”

Remote access is on & status connected (“relay established”)…

Are you getting the error message while trying to locally access the My Cloud using Windows File Explorer or Mac Finder? Or are you trying to use the WD Desktop app to access the My Cloud? The WD Desktop app has been End of Life since 2016 and no longer works with recent My Cloud firmware updates.

The username and password one uses to access a local network My Cloud is different than the username and password one uses to access the My Cloud when using the MyCloud.com web portal.

All of those.

When I try to access via Windows File Explorer it accepts “admin” + the admin password as valid credentials, but not the (correct) credentials for any other user account.

Same via web interface - admin is logged in fine, all other user accounts NOT fine (& tried on Win 7 & Win 10 machines & with FFox & IE on both).

I’ve never used the WD Desktop application.

I can login to files.mycloud.com (same username, mycloud.com-specific password), see the device and “do stuff” from there, but not login directly to the device with any account except admin.

I’ve now also tried switching off passwords for the accounts set up via the dashboard - same thing with passwords off…

I’m a bit confused. Are you trying to use non administrator accounts to access the user/password protected My Cloud Dashboard (ex: http://wdmycloud or https://wdmycloud.local)? If so, why?

The My Cloud Dashboard will reject the attempt to login from any account that is not the administrator account.

The My Cloud Dashboard is for configuring the My Cloud options. If one has enabled the administrator account password then the My Cloud will require one to enter in the administrator name and password to access the My Cloud Dashboard. If you want anyone on the local network to access the My Cloud Dashboard, disable/set to off the admin user password slider on the My Cloud Dashboard > User page. Example admin user with password option enabled:

If one does not enable the administrator password the My Cloud Dashboard will be accessible to anyone on the local network. That presents a potential security risk and risk of data loss if someone deletes Shares.

Edit to add: The My Cloud Dashboard is not what one generally uses to access the Shares (and one’s files) on the My Cloud. One generally uses Windows File Explorer or Mac Finder to access the local network My Cloud Shares. If one is using Windows 10 and does not see the My Cloud listed or cannot access My Cloud Shares, make sure SMB1.0/CIFS is enabled. Microsoft has disabled that Windows 10 option on new installed and through recent patch updates to Windows 10.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155

Ah, no. (& thanks).

“When trying to access the device from Windows File Explorer” is the real problem here. When I’m asked for credentials and:

  • give ‘admin’/pwd - it works fine;
  • any other user account - credentials are rejected (there are two other accounts set up, both with MyCloud.com accounts - both sets of credentials are rejected).

–N.

Can you post a screen shot of the login screen? And a screenshot of the error you receive when using a user name and login other than the admin login?

Here you go…

(This is with nothing in Credential Manager in relation to MyCloud or its IP address.)

(It does what it’d do if I’d typed the wrong password…)

One obvious thing to check is ensure the Username you are using has the appropriate read/write access to the My Cloud Share (using the My Cloud Dashboard) if one is trying to access a Private Share.

Also ensure the My Cloud is in the same IP subnet range as the computers attempting to access it. Also make sure all devices are using the exact same Workgroup name in the network settings.

This is going to sound a bit stupid but double check to ensure you are using the “username” entry for the User created in the My Cloud Dashboard > User page when asked for a user name and password when using Windows File Explorer. Do not use the MyCloud.com web portal user name/password as that is a completely different set of login information not related to local network access to the My Cloud.

Make sure to type the name exactly, if lower case, use lower case, etc. Next try changing the password to a simple password (ex: 123456) as a test. It is easy to goof entering a complex password and its also quite possible certain characters may not work for passwords on the My Cloud or Windows.

Another troubleshooting step. Try changing the user’s Username in the My Cloud Dashboard > User page (remember to save it after changing it). Try rebooting the computer if one hasn’t done so already.

Disable all security software as a troubleshooting step. Ensure the Windows Network Type is set to Private and not Public.

Years ago when people had problems with username and login to a My Cloud, in certain very rare cases, some had to put the IP address or My Cloud name before the username. Example: \\192.168.1.10\john or \\wdmycloud\john (if the back slashes don’t work try forward slashes)

One extreme troubleshooting step (if one hasn’t tried it already), perform a 40 second reset or a Dashboard > Settings > Utility > System Only reset to reset the My Cloud settings to default. The System Only reset does not remove user data.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

Mmm…

I just tried your “123456” password test and it let the user authenticate to “open” a Windows File Explorer session, so I think you’re onto something there!

The previous password (which was accepted on user-setup) had an ampersand and two digits after that ampersand then another character…so maybe MyCloud devices only accept/work with “weaker” passwords (great!)

Now I’ll try 2,000 other passwords and see what happens with each…

Thanks,

–N.

I’ve experimented with using the ampersand character and it worked fine in a password on a single bay v4.x firmware My cloud (test password was: &123456&).

If using Windows 10 it appears to be very finicky when it comes to logging into the My Cloud. Partly due to the account used to log into Windows 10 itself. I found that if the My Cloud uses the same user name as Windows I had to reboot the Windows PC after changing the password in the My Cloud Dashboard. Worse is the fact that Windows doesn’t like a user to use two different user names to access different NAS shares.

Also, I’ve had to reboot Windows after deleting/modifying anything via Credential Manager in order to get the changes to activate & “stick”…

And…the “ordinary user” credentials seem to authenticate access from some places (PCs) but not from others (they’re all on the same network)…