Issue with Accessing MyCloud

First, I did a search. We’ve had our WDMyCloud, 1-Bay Personal Cloud 4TB Storage (Gen2) for about 3-4 years. It CAN be accessed through the Internet; however, it cannot be accessed through WD Access. A couple of issues:

  1. About two years ago, I changed the name of one of the myclouds. If I go into the cloud through a browser - no problem. However, if I try to use WD Access, it only sees the old name. I did setup an administrator password but I am unable to log in (see 3 below). And if I do, will I be able to make changes to the names of the mycloud’s on the storage?

  2. One mycloud has the same name but it can’t be accessed through WD Access; can be accessed through the Internet. I tried the old password and the newer password without success and there isn’t a ‘forgot password’ option in ‘more choices’.

  3. I did select ‘more choices’ and selected ‘use a different account’ and tried to log in as both the user and then as ‘admin’ using both ‘Admin’ and ‘admin’ without success. Before I entered the password into the system, I first put it into my password manager and then copy/pasted to create the admin password. The admin account was created but no-go on actually using it.

What I see when I try to connect to a cloud on the 4TB drive is ‘Public’, ‘SmartWare’, ‘TimeMachineBackup’, ‘Cloud1’, and ‘Cloud2’. ‘Cloud1’ is a different name than what it used to be but ‘Cloud2’ is the same. Of course, these are made-up names.

Any help that anyone can provide would be greatly appreciated and, in advance, thank you!!!

Hello drnshaw,

You can perform 4 second Reset to reset the My Cloud dashboard device password and username would be “admin”. Also, you can edit or change the name of shares from dashboard (Dashboard >> Shares >> select any share >> edit or change the name of Share).
Moreover, name of My Cloud device can be changed from Device Settings from Dashboard (Dashboard >> Settings >> General >> Device Name >> edit or change the name of device).