WD MyCloud 2TB - access problems after name change


I’ve been through the previous posts and can’t seem to find a similar question that’s been answered.

I’m using a Mac and a 2TB MyCloud and currently I can only access the public area of my device - I cannot even get it to connect to the Dashboard.

The last time I had access I changed the name of my device, and have tried logging in to the dashboard using the the new name (http://newname.local) and using the normal (http://wdmycloud.local) - neither will connect.

Whether I connect to the device through the WD MyCloud desktop app or through Mac OS Finder, the only thing I can see is the Public area, none of my files are showing.

As mentioned, I cannot connect to the Dashboard through my browser, so I am unable to see what is going on there to change any of the settings.

Any help or advice would be very welcome - this is particularly frustrating after spending nearly a week uploading data to the device to backup and store files!!

Many thanks, iain

Log in via its IP address.

… or whatever it’s set to.

Thank-you, once I worked out what the IP address was I got it all sorted out. I appreciate the response.