iOS 13 files app - RESOLVED

Just updated to iOS 13 on iPhone; when trying to access My Cloud EX2 Ultra via the files app, it says contents not available - all my folders show in the app. Can access with no problems via the WD App. Also fully accessible via the files app on iPad running iOS 12.4.1. So far I cannot find any documentation regarding an iOS 13 issue. Update Sep 24 - installed iPadOS 13.1, files app no longer works with WD MyCloud, same issue as with the iPhone on 13.1, so clearly not compatible with 13.0 or 13.1 on either iPhone nor iPad hopefully it will get resolved quickly.
10-04-19: Was hoping the .195 update was going to resolve this, but no, it didn’t. The WD App updated 10-16-19 resolved the issue, works inside and outside my network, thank you for fixing the problem


I have the same error message both on iOS 12.4.1 (iPad) and iOS13.0 (iPhone). I just tried to uninstall and reinstall the WDMyCloud app on the iPad to see if it would solve the issue. No change : still the message « « Content unavailable. The folder contents cannot be displayed because of an unknown error. Try again. ».

It perfectly worked for me with iPhone 8 and IOS13 for a share with user and pw. Did you use a public share or a restricted one? Maybe that makes a difference?

WD My Cloud works on iOS 12.4 with iphone 8 and iPad, since update to iSO13 it is broken on iPhone 8, while i still can access it with iPad 12.4.1/
So my conclusion is that something is broken with iOS13 upgrade.

Hope WD willl check this soon as all mobile apps are impacted with any iOS upgrade, as it does with Android i suppose

I have the same problem with IOS13/ipadOS13. The Apple FilesApp does not display the folder content once the content has more than about 15 files/folders. If a folder contains only 10 files, then the content is displayed. Is this the case with you or is nothing displayed at all.

If I use the new function and integrate the MyCloud as a server in the Apple FileApp (just works in my home network), then everything is shown to me.

WD Community,

Thanks for reporting the issue with the My Cloud mobile app and iOS13 Files App integration.
We are already working on resolving the issue which should be available in the next mobile app release coming to you shortly.
We appreciate your patience and understanding and apologize for any inconvenience this issue has caused.

WD Staff

That is great news! Thank you for the prompt reply, greatly appreciated.

That’s really a big problem for me. Thanks a lot for the prompt reply and hopefully fast solution to solve the issue!

Really big problem for me too. I use it all the time and can’t with the new update to IOS 13. Hope WD sort out the problem soon.

Can you tell us when we can expect the update, so that the WD MyCloud is compatible with IOS 13 again?
I’ve had a lot of trouble with the incompatibility

My WD Cloud app version is 4.4.18. Is this the latest version BEFORE the iOS 13 update?

Anything on this yet WD?
I am having the same issue. When I try to access my cloud through the files app for iOS, there are folders that tell me “content unavailable”. A resolution would be great! I use this constantly.

I have same issue with my DL2100.

Dear WD Staff,

are there any news of a solution to the problem? Slowly I’m getting impatient because the WD My Cloud has no use for me anymore. I can’t understand why a solution takes so long.

Have the same problem.
Trying to access My Cloud from Apple Files App it shows “content not available”. I have however access from the WD My Cloud App as well from all other apps I use to access the device.
I believe it’s only with folders with a large number of files or directories, or withbig files.

Another issue I have is that I can add Dropbox to the WD My Cloud App, but I cannot add Microsoft OneDrive.

Any help is appreciated
Best regards

Listen. I have files on my MyCloud device which I need to access. I can’t access every folder. I get an unknown error when I try to access a folder with more than 15 items. Listen. Let’s turn that unknown error into a known error and then let’s fix it. Ok?! Email me the solution to this please

First fortnite and now this? Get real, guys. Gotta unplug at some point.

I too have the issue with iOS 13.2.3 on both iPad and iPhone but I have found a workaround.

  • install the File Browser Pro App;
  • open the iOS Files app;
  • select File Browser Pro;
  • click on Network Files folder;
  • it will ask you to authorize use (click on it);
  • once FB opens click on the Files text in upper left without closing FB Pro;
  • you will return to iOS Files Nanager and can. Ow use it correctly

The other option which I like is to not use iOS File Manager and just use File Browser Pro as it works very well.

With the latest update (version 4.4.19) the problem in the Apple files app on the iPhone as well as on the iPad is fixed. The folder contents are now displayed correctly again, even if they contain more than 15 files.

Nevertheless, the bugfix took me a bit too long to fix, Western Digital. Such a blatant bug has to be fixed sooner if you want to continue playing in a professional environment.

1 Like

Yup, I just confirmed that it is now working on my iPhone !!

Problem still exists, latest version of mycloud app and ipados.