Unable To Download Folders On My Cloud iOS App

Hello there,

I have a problem in which case I would try to download a folder from my My Cloud on my mobile IOS app. It would then fail while giving me the following message:

“Unable to complete this action. Folder downloads and copies are not supported from this location.”

This pretty much happens with any folder I try with. One share was public while another was private and the download would fail on both. I have no trouble viewing or accessing the files. In fact, downloading individual files still works, just not whole folders.

Also do not have any issues downloading/copying folders on a traditional Windows platform using Explorer. Just can’t download them through the iOS mobile app. Nothing wrong with the phone either, there’s enough space and all.

What is strange is that I have gotten it to work in the past before. A few months ago I was able to download folders on the mobile app when the device was new. But this feature is not functioning anymore.

Does anybody have any solutions?

Hi there and welcome to the WD community.

When you were able to do this, was this on your same iOS device? Did you do an update on your device or on the application?

I have attempted this on three seperate iOS devices (an iPhone, an iPod and an iPad to be precise) and it failed on all of them. My iOS is up to date and so is the WD MyCloud app. The firmware on the the My Cloud device is also up to date.

Anyone found a solution to this? I have the exact same issue as described here, it’s driving me crazy.


Unfortunately no, it still happens. I have not found a solution to the problem.

Here’s what’s weird though. There are times, though rarely where it does indeed work. And when it does work it (I will call this “Working State”) works for everything. In this state, My Cloud App is also able to compile all Music, Video and Pictures under their respective special tabs on the app. This only lasts until I reset or switch off the NAS device though. It seems to be luck based, as in sometimes I’ll switch on the machine and it I’ll have the feature work,

When it’s in the “not working state”, I’m unable to download folders or have the Music/Pictures/Videos tab compile the files. When I access the Music/Pictures/Videos tabs isn’t working it also gives me “WDGeneralNetworkError500”. The two issues are related I believe.

In either circumstance, I’m am able to download and view individual files just fine. It just won’t work for entire folders, which is weird.

Sorry to hear it’s still not working. The videos etc haven’t ever compiled for me in the app, that ‘500 error’ always came up. Folder downloads did however work once upon a time, indeed I still have a few ones saved locally in the app.

This issue is extremely frustrating as it’s one of the main reasons I wanted this WD product. I really hope someone can help out!

I am having the same issue on my iPhone. I am able to download specific files but not whole folders. This only seems to happen when trying to download music. I do not have this issue with pictures. The error message is:

“Unable to complete this action. Folder downloads and copies are not supported from this location.”

Please let me know if there is anyone that has found a solution. 

Hello There, welcome to the community.

What version of the application do you have? What iOS versions? What firmware is on your drive?

I have also the same problem! why? My firmware is v04 04 00 308 and ios MyCloud app is 4.1.3

Hello, we’ve passed this along to support.

Time has moved on, but the problem still exists; that is, the My Cloud iOS mobile app will not download folders (but will download individual files). I’m using the latest iOS (9.2.1), the latest My Cloud version (4.4.2) connecting to a My Cloud disk with the latest firmware (04.04.02-105) and a fully patched Windows 8.1.

The only ‘change’ from the original post is that I get the message “File not found - The file you are looking for is no longer available”.

Please note that the ability to download all files in a nested set of folders is functionality that used to exist. I can’t say definitively when the folder download ceased to work but my estimate is that it was working in Aug 2015 (with the same hardware, but earlier revs of the software).

Are we going to see a fix?

My problem was sort of solved by updating the firmware but it’s unfortunate that it hasn’t worked for you. My problem with app now is that the current version sluggishly slow. I have an older version of the app running on an inferior iPod Touch and it’s much faster than the latest version on my 6 Plus.

Personally, I might suggest you try some third party apps on the iOS App Store. They can work with the WD MyCloud NAS device. I’m trying one called File Explorer (it costs a few USD, but there is a free version you can try out) and it’s much better than the WD My Cloud app in my opinion. It has a download feature as well to save on your local device. If not, you can try some other third party apps.

The setup is fairly easy to do as well as well. I’ve seen some iOS apps that can detect your NAS on your local Wi-Fi fairly easy.