Internal Server Error - 32102 and Freezing on Utilities Screen

Good afternoon,

Just received a new MyBook. Plugged it in, went to it on my network (192.168.0.X), I can access some of the setup menus, but not all. Most of them either time out (sits at Please Wait) or gives me an Internal Server Error. I can’t get into the Factory Reset option because I cannot get to the Utilities menu, it just sits and says "Please Wait’ forever. What are my options here?

Thanks so much

Try the reset button for 4 seconds

Hi, We are having the same problem and are at a loss on how to resolve it. Did you manage to get it sortedI out your end? Could you please let me know if you have a fix as I would very much appreciate it. Thanks

I had similar problem, I also updated the firmware and reset 4s, but the problem still exists, I would like to know if I need to issue an RMA

I managed to get it sorted out. I had to SSH into the drive and perform the factory restore through there. After the factory restore, it works perfect.

  • Login to your Dashboard UI.
  • Change the web address to  http://mybooklive/UI/ssh and enable the option.
  • Download and install Putty from:
  • Configure PuTTY to create a connection to your MyBook Live
  • Login to linux using username: root with password: welc0me
  • run the script /usr/local/sbin/ noreformat

Then it will start the factory restore process. Let it go for a bit. You can try going to the Dashboard UI and the progress should be shown there.

Hope this helps.


Thank you very much for this solution.  Like alot of people, I have just purchased a new 2TB My Book Live and updated the firmware on set up.  I have had no access on the dashboard to utilities, users, shares or remote access.  I have been frustrated for two days trying to find a way of carrying out a factory restore to try and overcome these issues.

I used your fix which has worked a treat for me.  Not being used to Linux, it took me a while to work it out, but got there in the end.  I hadn’t realised I needed to force a reboot for the script to take affect.  Even managed to keep my existing data saved on the drive by using the noreformat command.

Thanks again Blackbyrd.:smiley:

Thank you very very much. Followed your instructions and all worked fine. Also missed the reboot bit first time. Man its a while since I’ved worked in unix environment !!

Cheers for that


Hi Mick101,

I’m having the same issue with my brand new MBL and I’m trying to follow those steps on W7…without results…

Can you (or someone else) tell me how to this factory reset on W7?

thank you in advance


azzuamarill, you need to type reboot in the PuTTY console a couple minutes after issuing the /usr/local/sbin/ noreformat command, otherwise the factory restore won’t complete. When you enter the dashboard after the drive reboots you should get an alert that the factory restore has completed.

I am having the same problems, downloaded putty, logged in and copied the command into the script. But it doesn’t seem to start the factory restore. Do I miss something?

The factory restore runs transparent and literally takes seconds as all it does is change some settings to default. As I said above you need to type reboot and hit enter in the PuTTY console after you run the script. Without rebooting the drive the factory restore will not complete.

Eventually it worked, I have added a reboot comand and after the reboot everything seems to work fine.


I’m getting  the following error:

MyBookLiveDuo:~# /usr/local/sbin/ line 34: echo: write error: No space left on device

I have no idea why I’m getting this, do I need to free up some space & if so, what & where?

Filesystem Size Used Avail Use% Mounted on
/dev/md1 1.9G 1.9G 0 100% /
tmpfs 50M 0 50M 0% /lib/init/rw
udev 10M 1.5M 8.6M 15% /dev
tmpfs 50M 0 50M 0% /dev/shm
tmpfs 50M 15M 36M 30% /tmp
ramlog-tmpfs 20M 4.7M 16M 24% /var/log
/dev/md3 2.8T 822G 2.0T 30% /DataVolume

@Jcko1 It looks like you have the MyBookLive Duo. Not sure if this would work the same on that drive or not. You might wanna try posting in the MyBookLive Duo forum

1 Like

Thanks, I’ve started a new thread there, hopefully get a response, but nothing yet.

Thanks this worked a treat for me. My first dip into the esoteric world of Linux too.

downloaded Putty…i think, there a ton of them.  Install, put the IP address and a black screen came out asking me for my logging…i wrote root and then it asks me for a password, which I can not write…there is a green rectangle, that dosent let me write anything…any ideas?  Thanks

TonyE, just type welc0me and hit enter. The password text won’t show up on the screen


I just bought mbl 2 tb and having the same problem.

I follow all the instructions,got inside putty but i think idont understand how to write the script?

can u do a print screen or explain in more details, this is what i did and didnt help

Hi - i tried this and it all appears to have worked

However, one snag -  i am now unable to ssh back in, despite the MBL being available. I get the error ‘Connection Refused’.

Any ideas would be helpful, although hopefully i won’t have a need to ssh back in again now things are working ;-p