Factory Rest on My Book Live?

Just purchased a My Book Live NAS and I’m getting continuous error messages when trying to do the simplest of things in the control panel (such as go through menus etc). I’ve read online that a factory reset apparently fixes this issue but the only problem is I’m also getting the error where Settings > Utilities doesn’t load so I can’t access the Factory Restore option! 

I have tried a reset using the button on the back of the NAS and this has done nothing.

Extremely disappointed with this product so far with how it doesn’t work ‘out of the box’. this is ridiculous! At the minute I have a £150 paper weight.

Anyone know a solution for this please?

ps. Also read online that SSH factory reset is an option but again, because Settings > Utilities I don’t have the option to configure the settings to enable SSH!

SSH option isn’t under utilities, it has it’s own page.


Thanks for this. I wasn’t aware it had it’s own page.

I’ve managed to SSH into the device using the Terminal app on my MacBook and have attempted to run the following command:

NAS:~# /usr/local/sbin/factoryRestore.sh

After pressing enter/return a new line appears that reads:

factoryRestore.sh: begin script:

What’s the next command? If i leave it nothing happens and if i type ‘yes’ then all I get is the letter ‘y’ x 100+ which keeps on going until I force the command to stop.

Managed to sort this. After running the factoryRestore.sh command I executed shutdown -r now and my NAS is now restored to it’s factory defaults and totally error free!

This is still really disappointing that all this has to be done when it’s straight out of the box.

Just wanted to say that after buying mine and running the auto firmware update my device was totally useless. None of the Web UI options did anything.

Enabled SSH and ran the above command in the console to reset factory and then ran the shutdown -r now command and I am now able to use the device!

Kind of scared to update it if I ever see a new FW release though.

Terrible state for an out of box experience.

Many thanks for the info here though - I would of had to return the device otherwise. 

i have the same problem but i cant solve yet,could you put here what do yoy writteythe putty system thas really help

Can someone please help, I tried factoryrestore.sh noreformat  but get command not found. Can some help?

The command is case sensitive. It is factoryRestore.sh not factoryrestore.sh

Guide with pictures


1 Like