My Book live problem after fw upgrade

Yesterday updated my book live 1tb firmware (01.04.06), but something goes wrong (an message error during process). The drive is fully reachable, but can’t go in standy status (blue light) and some functions via mybooklive.local/UI/ doesen’t works. WHat can i do? May I install again the firmware?

Try a factory reset and please check if the Firmware version is current.

Hi,

I have the exact same problem, and I’ve tried also the reset, but with no success.

I’m able to reach MBL via Dashboard and also able to perform backup, so everything looks OK, execpt for the problem to upgrade the Firmware. Whenever I try this (either manually or automatically I always get the “Error 5657” message").

Any help is much appreciated!

Thanks,

Shay

Got to ask. If you know how to get to the Linux shell then have you customised the MyBookLive to do things that WDC didn’t intend it to do?

Hi Myron,

Not sure I understand your question…

How is Linux shell relevant here?

All I’m trying to do is to upgarde the FW of the MBL (actually, the Dashboard gives always a messgae that there’s a new FW version and that I can upgarde…).

All I’m trying to do is via the product’s WEB interface (AKA Dashboard).

So - I haven’t customized anything at all…

Any help is greatly appreciated!

Thanks,

Shay

Ok. There are a number of people who dive into the back-end and change loads of things so I can see how that can break any update but this is not the case with you.

Give more details. Like what options under the UI don’t wotk and exactly how those functions don’t work.

This may sound strange, and I’m assuming that the re-boot option still works. If the reboot option does work then reboot the NAS no more than 30 times and before rebooting wait about 5 minutes then after that wait for the green light to stop flashing and stays on green and mostly steady before initiating the next reboot.

While looking through the insides of the MyBookLive (and changing nothing!) I did notice that after a number of days and also a number of hours, whichever comes sooner, the MyBookLive performs a full file system check.  Just don’t know after how many start-ups and how many hours (yet), the idea being to get the NAS to perform a file system check (and I assume repair).

Still, the more exact details you can give of what happens before, during and after the UI fault the better me and everyone else may be able to help.

Hi Myron,

Thanks for your assistance so far.

The step are quite simple:

  1. Turn on MBL and wait for the LED to be steady green

  2. Open MBL Dashboard -> a red excalamation mark appears on the upper right corner, when you click on it a message says “There’s a new firmware released. Please update your firmware”.

  3. Now, there are 2 options to perform the update (click the “update now” link within the message above, or, alternatively go to Settings->Updates->Update From File) - both are giving me the same result

  4. As described in step 3 above, wether I do it “automatiaclly” (e.g. letting the Dashboard to downlad the firmware file and install it) or manually (downloading the file myself from  http://www.wdc.com/wdproducts/updates/?family=wdfmb_live and trying the upgrade manually) I get the same error:

Communications Error

Except for that - everything else is working fine (i.e. I’m able to access the drive, able to perform backup, able to do reboot, etc.). The only problem that I have is to perform firmware upgrade.

I hope I got it all here - let me know if there is anything else that I can provide.

Thanks again!

Shay

The error shows there’s some connection problems, for more info refer to  KB 5657

Thanks Wizer,

That’s exactly my problem - I have no connection problem at all (e.g. I can reach MBL from all PCs in my home network, I have no problem connecting the Internet, etc.) - at least not one that I’m aware of or know to detect…

Believe me I’ve already read the KB 5657 before posting here…:slight_smile:

Any other suggestion?

Thanks,

Shay

You can do a manual firmware upgrade…

http://wdc.custhelp.com/app/answers/detail/a_id/5735

Thanks, but I’ve already tried that without success, I’m always gettting the same error…

Thanks,

Shay

Just for the moment, but you may not need to use it, while the dashboard is still working, turn on SSH.  Do that by signing into the dashboard and then going to http://MyBookLive/UI/ssh then enabling the option.  Replace MyBookLive with the name you gave your NAS.

The reason for this is that just in case the dashboard becomes totally inoperative then someone may be able to help you restore it’s functionality.  You can always disable SSH whenever you please.

I leave mine on permanantly (and changes the root password from welc0me) for just such a reason.

Just wondering that your best bet (I assume you’ve already done this) is to, using the dashboard’s request support button sent a system report to WDC support together with the exact description of the fault.

As the the KB, it could just be possible that your network router/switch could be the problem.

It is strange why you’re getting the network error because the update from web and update from file are basically identical (had a look at the scripts) except that the one which gets the update automatically calls the script that updates from a downloaded file.

I wondering if during the update the LAN link between the NAS and router is momenterally dropped, the router may get confused and take too long to re-establish it’s link with the NAS so the java script and/or java applet that gets downloaded into the browser times out?  How long does it take for the communication error to appear?  Is it nearly instant or does it take a while?

Another thing you could do is assign a static IP address within the subnet of your router and then assign a static IP address to your NAS.  Once that’s done use a cross-over LAN cable to link the NAS directly to the computer’s LAN port and try the update again?  (This removes any switch and/or router from the equation).

Thing is, you should not need to do this.  When allowed mine to upgrade is went without a hitch.  The router I used was a WRT160N but now have has reason to upgrade to a router that does gigabit speeds.

shayw wrote:

Thanks, but I’ve already tried that without success, I’m always gettting the same error…

 

Thanks,

Shay

As far as I can see your only problem is the error mesaage that comes up? As you can access your dashboard can you tell us what firmware is reported under system / updates.

Hi,

 

Myron - I did contact WD support, but after 1:15 hours with them on the phone the issue is still not resovled. They’ve tried to remote connect my PC and take a look on the MBL, but from some reason I could see the “Allow” button on WD support page for them to take control (probably router or ISP issue)…

We’ve tried many variations of connections (i.e. with and without the router), we’ve tried to replace ethernet cable - all gave the same error.

Regarding to your second question - once I click the “Update From File” button, I get the “Extracting File…” window, and then the window that says “Update is being done…don’t unplug the device…” (the one with the progress bar in the bottom) and then right after I’m getting the Communication Error message.

 

richUK - I’m currently using MyBookLive 01.02.03 : MioNet 4.3.1.12, and trying to update to 01.04.06

 

Help…

Shay

Another thought…  Uninstall every version of the Java run-time on your computer and then install the latest Java run-time.

What browser and OS are you using to connect to the admin web interface?

I had the same error message while trying to change NTP settings and it turned out to be Chrome.

As an FYI - Chrome is not a supported browser on the My Book Live interface. IE 7+, Firefox 3.5+, Safari 4+ are all supported.

I’ve seen some connection errors that occur with wonky DNS servers. Try setting the drive up with Statics and using the Public Google DNS servers: 8.8.8.8,  8.8.4.4.

If you are still unable to install a firmware update, send me a PM with your contact information to setup a troubleshooting session. I am a level 3 Support Specialist for WD, dealing specifically with our Network Drives, WD Photos and MioNet products.

WDTony wrote:

As an FYI - Chrome is not a supported browser on the My Book Live interface. IE 7+, Firefox 3.5+, Safari 4+ are all supported.

Just out of interest I have no problem connecting to the interface with a chrome browser.