Firmware Upgrade on MBL 1TB

I’ve seen many threads similar to mine but as yet not really seen a solution and I’ve logged this with WD support but have waited 4 days for a response so I’m close to taking it back.

I am unable to install the latest firmware on my brand new My Book Live 1TB network drive.

Full details:
Model No. = WDBACG0010HCH-EESN
current firmware = MyBookLive 01.04.06 : MioNet

If chose check for update the following is offered = MyBookLive 01.05.07
Error 5657 and have changed cable, checked that I am fully connected to the internet and even turned off the Router’s Firewall.

I have downloaded apnc-021009-124-20111113.deb and attempted to run a manual update but the web paage times out.

Although I use Chrome as my default browser I have also attempted all of the above via IE 9.

I’ve tried from my Windows 7 Notebook and an XP Desktop.

I’ve completed a factory reset and symptoms are the same in that I either get a 5657 or it sits at an uploading page for hours (longest I’ve left it so far is 6 hours).

HELP. If I am unable to perform such a simple thing as installing firmware I am getting to a stage that I don’t think I could trust some of the other features. Also if WD are going to send out an automated response to a support question saying that they will attempt to get back to me within a working day based on operational hours then some form of un-automated response should have beeen made within this time. Poor show WD.

Yours with fading trust.


How much data do you have on your drive. I think I have seen something about it timing out if the drive is almost full.

I’ve had this web page thing timing out when trying to apply the latest firmware update but got round that by enabling SSH, sending the update file to the Public folder and directly invoking the update-from-file script.

Do you want to try that?  I can give you instructions BUT before you attempt this, back-up everything off the MyBook Live you wish to keep.

Its a brand new drive and I’m not trusting any data on it until I am sure that I am able to upgrade the firmware. Otherwise it goes back and I try a different brand.

Myron, This sounds like it could be a plan. As the drive is new I’ve not actually started transfering data on to it. Could you give instructions?

Many thanks


As your NAS is new I will assume for the purpose of these instructions what your MyBook Live is named: mybooklive

Download the firmware file and copy it to the Public share from:

Log onto the MBL’s (My Book Live’s) dashboard. Once you have done chat change the web address to:

I would advise that you leave SSH enabled and change the password from the default of welc0me to something that’s a lot more secure, difficult to guess and easy to remember.  Once you have gained access to the Linux command line you can change the password using the passwd command.

Tutotial on how to download and install PuTTY
(Within the tutorial above substitute the Hste Name for the name of your MyBook Live, which is:  mybooklive )

Assuming the name of the firmware file you have downloaded is apnc-021009-124-20111113.deb then issue the command . . .

/usr/local/sbin/ /DataVolume/shares/Public/apnc-021009-124-20111113.deb

Two lines should appear showing the current firmware vission and what the new firmware visrsion will be.

Now…  This is quite important.  There will be no other feedback.  It’ll look like it’s hung but it has not.  Do not terminate the PuTTY session to the MyBook Live as this may kill the console process and prematurly terminate the update process.  When the firmware update process completes your MyBook Live will reboot.  A message should show on the console statiing that the MyBook Live is going to reboot.

I has a similar problem. Tries to upload the firmware file using the Dashboard UI and it got stuck. When I had a look at the back end the firmware file was not being written to the disc, so I bypassed the Dashboard UI and copied the firmware file to the MBL manualy and invoked he upgeade script manually.  It did not take too long to upgrade.

Before you do upgrade there is chatter that you need to first upgrade to the last version of the v1 firmware and then upgrade to the latest v2 firmware but then there is also chatter that does not need to be done and to just update it to the v2 firrmware.

As your MBL is new and you’ ve not put any data there is no risk of losing data.

I’ve updated my firmware this way a few times without a hitch.  What is be advisable is once SSH is enabled and the firmware file copied to the Public share, to shutdown the MBL correct way (don’t just pull the plug!) , power it up, login to the Linux operating system on the MBL usign the PuTTY program and the command given, initiate the firmware upgrade.

Proof that the method works is that my MBL is still fully functional.  Enable SSH first because my experience of the previous firmware is after a reboot the Dashboard UI vanished so the only access I has is via PuTTY. Once the current firmware was applied the Dashboard UI came back. I don’t know why the Dashboard UI on my MBL vanished after a simple reboot but then I also remembered that a full shutdown and power-down/power-up once brought the Dashboard back.

I wonder if this could be the root of my problems…

I’ve downloaded the firmware and attempted to copy the file to the Public folder using Windows Explorer. No luck reports a problem connecting to the mapped drive. To test the share I created a folder, copied a 1k file in to it, amended it, deleted it and then deleted the folder; all with sucess.

I’ve tried using DOS commands. they failed. I rebooted all hardware and even stopped and restarted Windows Explorer and then tried XCOPY from a CMD prompt. the following ocurred:

C:\temp>xcopy *.* y: /j
Overwrite Y:\apnc-021009-124-20111113.deb (Yes/No/All)? y
Sharing violation

Any ideas?


Also here is the results of the SSH attempt:

MyBookLive:~# /usr/local/sbin/ /DataVolume/shares/Public/apnc-021009-124-20111113.deb
dpkg-deb: `/DataVolume/shares/Public/apnc-021009-124-20111113.deb’ is not a debian format archive
dpkg: error processing /DataVolume/shares/Public/apnc-021009-124-20111113.deb (–install):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:

Ok. So the archive seems to be corrupted.

Try this . . .

First reboot your computer and make sure no other process on your computer had locked the upgrade file for excusive access.

Log onto the Mybook Live’s Linux command shell.

Issue the command . . .

/etc/init.d/samba restart

Download the firmware to file to the Public share and make sure it is 126749376 bytes in length.

Just as a precaution, restart your computer.

Check the checksums of the upgrade file now on the Public Share . . .

CRC-32: 727a44fa
   MD4: 946d68f2998b2ceeae28f6187eae8068
   MD5: 86bd2e7a788798408222049d88958d00
 SHA-1: 83b5eb4fbf6151b3c597a92908957005d5e3af75

Make sure the above is correct.

You can do this on the MyBook Live with.

md5sum -b < /DataVolume/shares/Public/apnc-021009-124-20111113.deb

 If the MD5 sum is not 86bd2e7a788798408222049d88958d00 then the upgade file you have got is not not complete and corrupted.

If corrupted then try and re-download the firmware file.  If it’s still not installing even though the upgrade file is intact then need to scratch my head a bit more.

Copy the firmware file to the MyBook Live using the normal copy command using theb /B option. Don’t use xcopy.

I’ve had situation in the past where, for some unknown reason, the web browser will just stop downloading before everything has been downloading and keep what has been downloaded. It appears that the download completed ok.

We have sucess. Horray.

Many thanks for your help Myron I’d never done it without your help. But what a faff. why oh why shouldn’t the normal routine work on a brand new device.

This is a strange one.  Possibly multiple issues.

  1. File downloaded via the web browser is incomplete. I’ve had this before and this is clearly NOT a fault of the MyBook Live.
  2. Yo_u’ve got to the Dashboard UI and trying to upload the firmware but then it just gets stuck and does not complete._ This happened to me. Everything worked fine until I rebooted my MyBook Live (aka. MBL) prior to upgrading the firmware and after the reboot the Dashboard UI vanished. I copied the firmware file to the Public folder and invoked the script directly to remove the Dashboard UI from the equation.

Anyway…  The upgrade happened and at present everything is working find BUT I am at present not using the Remote Access, Twonky and iTunes services. They are disabled.  Don’t require them.

For the second issue I honestly don’t have a clue and I see this is a odd one for WD to solve because there a lot more people who just don’t have any issues with their MBL.  Strange one indeed.  Glad you’ve got it sorted out.

Word of advise.  Keep SSH enabled, change the root password using the . . .


 . . . command to something easy for you to remember and very difficult for anyone else to guess and keep a back-up of all the stuff you can’t afford to lose. The back-up strategy applies to ANY and EVERY storage device.