Can't update My Book Live to latest firmware

Hey folks

I’m trying to update my My Book Live’s firmware from its existing version 01.04.06 to the newest firmware, but can’t get it to work. It doesn’t matter whether I’m doing the auto update or a manual update, it times out with a 5657 error. 

I’ve tried:

a) disabling my F-secure firewall and AV software

b) setting a static IP for the drive and setting that IP as the DMZ on my Billion 7800N router

c) plugging the drive directly into the second lan on my PC, as well as the switch it was originally plugged into and directly into my router

I’m at a loss as to what to try next - I read on these forums that I should upgrade to the 01.05.07 firmware first, but I can’t find old firmware versions on WD’s site. 

Any ideas? I’d really like to make the most of the new Personal Cloud tech with my new iPhone 4S.

you need to update to the very last of the 01.xx.xx firmwares to prep the machine to update to the 02.xx.xx firmwares.

i also got that comm err.  I got that when I tried to do back to back updates.  I had to do a shut down from the dashboard and the replug the power and wait a day or two.  I think the MBL copies it’s currently valid firmware to a mirror location so that it can fall back if your next firmware update fails.  So maybe it needs time to verify the current FW and copy it over and confirm the copy. just speculating.  I was able to update through the interface eventually, not via loading a file manually.

Thanks for the tip - how do I  do this? The auto updater doesn’t work at all, and I can’t find any download links for older firmwares on the WDC site. Believe me, I’ve looked long and hard!


check this link, it should give you answers to your questions about a manual update and guides you to all necessary firmware versions: