I have a new my book live and I have tried multiple times to update so I can use  WD2go but everytime it realizes I need the update and it acts like it is downloading it but after a while it displays a error message  “communication error 5657”   I know I am connected well but it just won’t finish the download. Any help would be appreciated!

You might try updating via file mode instead of using the automatic installer…

Any chance you could tell me how to do that?

Check this page:


Well I downloaded the update and clicked on the update from file box and it acted like it was updating for about 45 min then I got the same communication error message just like when I tried the auto updater. Any ideas?

Is your MBL connected to your net in such a way that it can access the Internet?

It is plugged into thr router, it should be able to

my solution to this was to try again the next day, and that worked.

I have this same issue trying to manually update firmware from 01.04.06 to 2.10.12 - 129 (3/14/2012) and I get the 5657 communication error after 45 minutes.  It never leaves the Importing File message. I’ve turned off all firewalls but it did not help.  Any other ideas?  I already have a lot of files on the disk.

What Browser type and version are you at?

What My Book Live firmware version are you at?

knowing these will help.

I am using IE 8.0.7601.17514.  Current firmware is 01.04.06.

I’m having the same issue and I’m using Google Chrome.