Firm Ware Up date to MyBookLive 02.32.05-046 has caused access errors

Since I updated the FW  to the latest Version the 2TB My Book Live has lost the access to create Users, the Utilities & Security Password.

The Unit has also Started to Drop offline on the Network and the only recourse si a Hard Re-Boot ( Unpluging the Power)

I just purchased the Unit Last Week and Followed the Instructions out of the Box which led me to the Up-Date Function and from there it has been Down Hill… Any one else have FW Problems? 

I have experienced very similar problems. I recently bought a 2T MyBookLive and following installation I updated the firmware as prompted - since that point I received an error message against most actions I tried to perform e.g. add user, add share etc. I could not access utilities at all, so could not perform a factory reset. Returned unit to vendor and now have a replacement. This time I won’t apply the firmware update.

I think there are many who have had this experience. I am one of them. There is a post from nfodiz which explains how to do a factory restore when you have no access to the dashboard utilities. See

Many thanks for your suggestion jac1955 - it looks as though that process would work - and I’m grateful for you pointing it out.

But as far as WD is concerned, I didn’t by this kit to have to do workarounds of this type. It should all be available easily throughthe UI. So I returned the MBL to the retailer and got a replacement. I then set that up WITHOUT updating the firmware and it worked fine until I realised that the WD Smartware software was using approx 60% of my CPU capacity pretty much all of the time. For me that was the final straw, will be returning the MBL permanently and getting my money back. It just isn’t properly developed and I don’t feel comfortable trusting my backups to such unstable equipment.