MyBookLive 2tb locked cant access utilities and still cant enable remote access

I got my 2tb MyBookLive yesterday. I managed to get it backing bup all my files ok then started to look at http://mybooklive.local (this is the dashboard right?) to look at setting up the remote access.

I couldnt enable it, so i googled it, this took me through a journey of trying static/dhcp/port forwarding none of which worked some suggested i make sure im running the latest firmware.

The threads here regarding firmware i found really confusing but it seemed to me that manal updating was disabled to make sure nobody put bad firmware on as there are issues. I was under tyhe impression as long as i used the ‘check for updates’ method id get the right firmware.

I believe I was using 052, i tried check for updates several times and was told im already using the latest firmware, then it  found new firmware for me to use, a few times it downloaded and then errored before installing but eventually i got it updated.

im now using 046 my drive shows as locked in Smartware although i never set any username and password i tried blank fields clicked ok and nothing happens, weird thing is even if i put text in the fields and click ok it still doesnt seem to try and authenticate.

I still cant enable remote access.

Clicking utilities displays please wait and hangs there.

Does anyone have any good news for me?

I am having a similar issue. It was suggested that i check my router ports. I am going to work on it this evening. hopefully with positive results.

Same problem here,

It arrived today, loaded everything, unfortunatly downloaded the new firmware, nothing else set up.  Now getting various errors.  Have trawled the forums and it keeps coming back to ‘do a factory reset’.  This can only be done thru the Utilities part of the user panel, but it just hangs.

Tried using IE and Chrome but the same happens.

If no joy by tomorrow evening, its going back.

After a very helpful conversation (Shock) witha chap on the WD tech support desk (I went old school and phoned them), he confirmed that the firmware version I updated to straight out of the box (version ends with 05-046) is utterly stuffed and they’re waiting for another update.

His recommendation was to RMA to the store I bought it from, so back it goes.  He suggests not to update the replacement, and I wholeheartedly will not be doing that! Probably ever.

Hope that helps folks.

Thats bad news, why are WD sending this firmware out if its broken? from the looks of the forums it seems others are using 046 fine can anyone confirm?

any progress?

i  have the same issue and the store isn’t going to take back the product.

does the router setting helped?

Sorry, nothing from me I’m afraid. The device is going back for a replacement. I would suggest if you cannot send it back, then sit tight for a new firmware update. Outside of it wiping your data, it couldn’t do any more harm could it?

So why can’t they make the previous firmware available via download. I see in the settings tab you can update firmware via file. .    or possibly re-release the previous version with a new version number so our devices will pick up the new one. .    christ I have had this thing for 5 frigin minutes and it’s already useless…   [Deleted] WD? 

still no firmware update?  seriously?    i might as well break out the old radio shack cassette deck andc start backing things up…    uggggg

Hi all,

my second post and still it’s a big winge (sorry)

Can’t get any user settings or utilities working. I have firmware 02.32.05-046 and have all the problems as listed elswhere before. Unfortunatally I did a firmware update straight from the box :(, then had an issue and found this forum.

WD is there any update to this problem , this is a new drive straight out the box and it DOES NOT WORK !!!

I’m new to WD hardware and the posts here don’t show a very satisfied customer base …

ps. what is RMA ?

@ztech6 if you are getting error 3xxxx when trying to access different sections of the dashboard, follow this simple guide and you should be all fixed up.

1 Like

nfodiz wrote:
@ztech6 if you are getting error 3xxxx when trying to access different sections of the dashboard, follow this simple guide and you should be all fixed up.

Woohoo !!

Thankyou nfodiz, the above procedure worked. I’ve no idea what I was doing but this easy to follow guide was … well…easy to follow :slight_smile:

Thanks again.

Yeah it almost might be worth a sticky IMO as I see a lot of people running into this issue on brand new units after a firmware upgrade.

Glad you are all fixed up :slight_smile: