[GUIDE] Fix Dashboard Errors 3xxxx


#1

I have seen several requests for an easy to follow guide on how to Factory Restore a MyBookLive when the Dashboard is throwing errors and won’t let you do anything, so here it is.

Please note that this guide will not delete any data on your data partition but you will need to follow the steps at the end of the guide to re-link your shares.

  1. In a web-browser go to http://mybooklive/UI/ssh and you should see the following. Tick SSH Access Enable

  1. If you are a Windows user, download PuTTY from http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe
     2a) If you are using a MAC, open Terminal and type ssh root@mybooklive.local and then hit enter and when asked,

       enter welc0me for the password (Continue on to step 5)

  1. Open PuTTY and enter mybooklive in the Host Name (or IP address) box and click Open

  1. Now we need to enter the login information
    type root for the username and hit enter
    type welc0me for the password and hit enter
    (The password text won’t show up in the PuTTY window)

  1. Now at the MyBookLive:~# prompt you are gonna type
    /usr/local/sbin/factoryRestore.sh noreformat
    wait a minute
    and then type
    reboot

  1. Wait for your MyBookLive to reboot and when it does, go to the Dashboard and you should see

  1. Factory restore complete and you should now have full dashboard access

If your shares are still listed in the MyBookLive dashboard but are not accessible, rename the shares and then rename them back to get them linked properly again.
EX. Movies > Movies1 > Movies
If your shares are missing in the MyBookLive dashboard, recreate them in the dashboard and you will be able to access your data again

A reboot is required to get the share and drive usage totals to reflect the actual data usage after these changes
____________________________________________________________________________________________________

Take a look at my other guides

How to open/unbrick/recover data/replace the hard drive on a bricked MyBookLive with no SSH access
http://community.wdc.com/t5/My-Book-Live/GUIDE-How-to-unbrick-a-totally-dead-MBL/td-p/435724

Upgrade/Downgrade your MyBookLive firmware…Also contains a reset button script mod to restore Factory Fresh Firmware
http://community.wdc.com/t5/My-Book-Live/GUIDE-Restore-Downgrade-firmware-via-the-reset-button/td-p/481588

Reset button script mod that also enables SSH access
http://community.wdc.com/t5/My-Book-Live/GUIDE-Reset-Button-script-that-enables-SSH/m-p/490580/highlight/true#M15534


My Book Live 2TB
[GUIDE] How to unbrick a totally dead MBL
3TB MyBookLive is holding all my data hostage
31550 and 31564 errors. Hanging when trying to access Utilities
WD MBL keeps initializing after failed firmware update
Remote access doesn't work steadilly
My MBL 3 TB can not access the internet
Unable to map public share of MyBookLive on one of my Win 7 Laptop
Problem to see & acces folders after fix dashboard errors 3xxxx
MBL file to big for file system now lost folder ! help please
MBL file to big for file system now lost folder ! help please
My My Book Live 3Tb suddenly can't be accessed by my WD TV SMP
2 devices cannot connect to My Book Live mapped network shares
Factory reset via SSH, still no write permission
Experiencing access issue on MBLD from any device
WD MYBOOK LIVE - Unable to access "Public" share by browsing from Windows Explorer: A solution
Fix dashboard error 31125
MyBookLive 2tb locked cant access utilities and still cant enable remote access
#2

Nice, bookmarked. :smiley:


#3

Follow these steps to restore the factory settings, the data on MBL will be lost?


#4

No data will be lost… noreformat at the end of the command “/usr/local/sbin/factoryRestore.sh noreformat” prevents the script from deleting the data on your data partition.


#5

I left a kudos, sweet job man.

I had to change out the “mybooklive” for the number url I see when I use the dashboard.

But got it to reboot and go back to factory settings which is what I needed.

Thanks m8.

ICE


#6

Thanks for the guides. Did the factory restore and my dashboard now no longer hangs at the Utilities tab. Kudos!


#7

Thank you! Worked like a charm!


#8

Thanks!

Solved my problem with a crappy firmware update on a brandnew MBL 2TB

Regards,

Kris


#9

Thanks!  It worked for me.  Mine was having all these errors out of the box and even after i have updated the firmware

I’m nervous about this product, it didn’t make a good impression.  Not at all :confounded:


#10

dammit!

The 32034 went away, now this.

32111  - Error creating user: Failed to create user account. Please make sure you have the required privileges and sufficient disk space for this operation and try again

:manmad:


#11

Have you put any data on the drive yet? If not, try doing a quick factory restore from the dashboard to see if that clears it up. Just note that this WILL delete any data you have put on the drive.


#12

@nfodiz

Did a quick factory restore from the dashboard and so far all the errors are gone.

Thanks!

But it really **bleep** that this 1-day old NAS is not living up to my expectations :manfrustrated:


#13

nfodiz,

Thanks! i spent over an hour on the phone with help desk and they couldnt solve this!  After performing the reset i do not get any errors?

Do you know why this occurs, seems like it happens often.


#14

Alfred69

Seems some people are getting new drives out of the box with a newer firmware version (02.32.06-006-20121010) on it than what is available online. Not sure if the new firmware version is the problem or not… Firmware upgrades have also caused people to experience this issue.


#15

I joined this AM, and right out the box, my issue has been corrected.  Not sure who specifically to thanks, but thanks to the user/knowledge base for the help.  My device no longer hangs up, and I have access to entire dashboard to create users and remote access priveledges.

1 question - The “SSH” that I enabled in the begining of this thread, do I have to disable it now?  With it enabled, am I “exposed” so to speak?  Thanks.


#16

Yes, it could be a security concern. Obviously don’t forward port 22 to the MyBookLive on your router. If you do decide to turn it off and lose dashboard access, you won’t be able to repair your OS without taking the drive apart.

Having said that, you can turn it off after you follow my guide below so that a simple press of the reset button would enable SSH access if you were to lose dashboard access and weren’t able to enable SSH from the dashboard to fix it.

http://community.wdc.com/t5/My-Book-Live/GUIDE-Reset-Button-script-that-enables-SSH/m-p/490580#M15534


#17

Thank you.  Please pardon my ignorance.  If I turn it (SSH) off/disable, will it affect my remote access priveledges or anything else relating to routine access and use?  Thanks.


#18

No not at all


#19

Wow!  Thanks for the assist!  Much appreciated.


#20

PLEASE HELP!

 


Followed all the steps but couldn’t complete step 6.

Its now stuck on the amber light :frowning:

what shall i do?

Is there a way i can hard reset this???

Please help me