MyBookLive Dashboard Inoperative


I’ve just set up a new PC and copied all my MBL stuff across. I needed to check some settings, so opened the dashboard, only to find it virtually inoperable. No links appear and direct access (e.g. http://mybooklive/ui/shares#) opens the appropriate frames, but while information will popup, no links work.

It’s not a browser problem (javascript is enabled and I’ve tried different browsers on different machines). It looks like a permissions thing, so I ran the setup program on the new machine to see if that would reset anything. It didn’t.

Other info - I can SSH through Putty as root, but I’m not very familiar with Linux. About 12 months ago I installed Twonky 7.2.1 that way, because the MBL media server (DLNA, not Twonky 5) didn’t work with my audio gear. Relevant because I don’t want to reset to factory and perhaps lose my Twonky setup.

I apologise if this is a familar problem; I’ve just spent hours trying to track it down. Note, it’s not loss of access to the dashboard but a useless dashboard. Here is what I see @

Thanks for any help,


The image, this time hosted:

Can I force a login somehow? Maybe I need to start again. No-one is responding, so this is either:

a. So simple I’m being a moron. If so, call me a moron (you won’t be the first, ask my wife) and put me out of my misery.

b. A unique and complicated problem. If so, please let me know you are thinking about it.

At the moment I’ve stopped Twonky, have access to the public share in Windows 7 and can SSH in. Surely there must be a way to get an operable dashboard? I am concerned that any factory reset will lose Twonky 7 and my 1.7 TB of shares.

I’ve inspected the dashboard Web page html, and it doesn’t look like there is any hidden functionality. I am seeing what the MBL server is sending. Why isn’t it sending me anything clickable?

It gets interesting now.

For some obscure reason the full dashboard returned and I explored the options. I got as far as ‘Settings’ and (I think) ‘Utilities’, then it hung with the spinning wheel. So…

  1. I closed the browser and tried to re-open the dashboard, but this time it was completely gone.
  2. Still had SSH so I ran the script - ‘/usr/local/sbin/ noreformat’, followed by reboot.
  3. Everything good, Twonky even restarted automatically.
  4. However, SSH was disabled, so I went looking for it. I could load the page ’’, but checking the box wasn’t taking (no ‘OK’ or ‘Save’) - no SSH.
  5. Went looking for it in the dashboard. Got as far as ‘Settings’ and ‘Utilities’ and the dashboard hung (spinning wheel).
  6. Pulled the plug on the MBL and reconnected, but no more dashboard. Nothing loads now.

So now I am back to square one, but this time with NO SSH!

So this has been a long journey from disabled dashboard with SSH to disabled dashboard with no SSH. What a crock. Fortunately my public is still accessible for now via Windows. Synology looks great from here.

I cannot think of what the issue would be, since you did a restore already. Did the unit do a firmware upgrade? What is the last change you can think of? Not just MBL but your network in general.

As a last resort you could try to downgrade the firmware, debrick guide V1 has the links.

Nevertheless, WD or Sysnology, whatever you do, always always have backups for important data.

Happy reading!

Thank you for the reply. Much appreciated.

No firmware upgrades - didn’t want to lose my installation of Twonky 7.

I solved my problem - liberated the hard drive and discarded the plastic. All my data is accessible via a USB dock and Disk Internals Linux Reader. But that was not critical - I am obsessive about backup and the MBL was not the data source, or even the primary backup. I keep copies on a DS214, as well as on portable hard drives, two of which are offsite. No, I just wanted the MBL to work as advertised.

I apologise for getting grumpy; that doesn’t help. But you’d expect the serving of simple config Web pages to work. If not, then enable SSH by default. The MBL hard drive is keeper (3 TB WD Red). I’m buying a friend for it and they’re both going into another DS214. DSM is the go - no more flaky WD dashboards.

Yeap, that is one way.

For me, this is the best low/home budget NAS I ever had. Also, I hardly ever access the dashboard, maybe 2-3 times a year if any. You did make me check it, but all good!!!  :smiley:

Like you, I do not have autoupdate nor I update manually ever. I will if I encounter issues (knock on wood…)