32102 - Error retrieving user information: Internal server error

Hello!

Just got a new My Book 2T. First thing I did after installing was to update firmware (Guess this was a mistake). Can’t really do anything with this new product. Can’t create users or enable remote access. Read in some threads that should restore to factory settings. Problem is that Utilities won’t work either.

Is there a solution for this? Thanks!

I am having the exact same problem. Exact same device. Just got it today, prompted for an update, I let it go ahead. Now I can’t even use it because everything results in an internal server error or it hangs. Can’t do a factory reset either, utilities hangs…

Great investment so far.

Bought product yesterday. Update firmware today and have the same issue.

I have exactly the same problem and I am very interested in any support of WD as the automatic support tool does not work anymore!

Greetings,

I bought a 2 TB MBL yesterday and faced the same issue: all network activities were rendered impossible after updating the firmware to the latest version.

Here is what I’ve done to restore the factory firmware and get the MBL to work properly again:

Edit: First go to http://mybooklive/UI/ssh and make sure that “SSH Access” is checked.

  1. Download and Run PuTTY SSH Client ->  http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html.

  2. Enter the IP address of your MBL (can be found in the device properties) and click Open.

  3. Use “root” (without the quotes) as username, and “welc0me” (w/o quotes) as password.

  4. Enter the following command line: “/usr/local/sbin/factoryRestore.sh noreformat” (w/o quotes).

  5. Wait for 3-4 minutes and make sure that the LED on the MBL is green and not flashing.

  6. Enter the following command line: “reboot” (w/o quotes).

  7. Wait for the MBL to reboot (up to 5 minutes).

If everything worked correctly, you should be able to access every feature of the MBL Dashboard!

I had to ignore some warning windows along the way, but it worked for me, and I hope that it solves your problem too!

3 Likes

Thanks for the attempt to help but when I run PuTTY I get the following error after I eneter MBL IP address: “Network error: Connection refused”  Any suggestions?  Also, should I leave the port set to 22?

Sounds like you don’t have SSH access enabled. See if you can enable it by going to

http://mybooklive/UI/ssh

Tick the enable SSH box and try to login with PuTTY again

1 Like

Thanks, that was exactly why I could not login and enabling SSH allowed me to run PuTTY. 

However, in my case it still have not fixed the issue.  I still get the same errors across just about every menu feature and still unable to access Utilities at all.

Really appreciate your help.  I have been going back and fourth with email support and so far have gotten no resolution and to date still was not able to get them to tell me how to do a factory restore w/out being able to get into Utilities, which is what they replied with previously.

I have also been sent a message asking me to provide screen shots of the errors so they can forward then to Engineering but have not heard back from anyone yet.  Meanwhile. My Book Live is still My Book Dead. :confounded:

I stand corrected.  After using PuTTY and doing the steps, the drive rebooted and initialized.  I went into the menu and still had the same errors.  However, I then performed a reset that tech support requested I try, the previously did not work for me and when it finished I am no able to get into the drive and menus without any errors.

The reset I did after running PuTTY steps were:
1.  Unplug power cord from  MBL

2.  Using a paperclip, press and hold reset button located on backside of MBL above the Network cable connection.

3.  Plug power cord back in, while still holing reset button and continue to hold reset button for 20 seconds.

After MBL rebooted and reinitialized, I was then able to get back into Drive w/out any error.

Thanks again to all that contributed!

Also, does anyone recall which firmware version upgrade caused the issue?  My reason for asking is after doing the factory restore, I am now using 02.32.05-046 which shows to be the latest?  I did not try and update after getting everything working and if I check for updates it states there are none, so have they pulled the firmware version that was causing the problem.

Thanks. This worked perfectly after hours of attempts on 4 different computers.

:smiley:

Just out of interest, does your device now sleep properly? I had the same problems after firmware update, followed all the instructions above, and my 2TB now seems to work properly except that it never sleeps because there always seems to be some disk activity. It does sleep if I disconnect my computer (with Dashboard on it) from the network, but apart from that it seems to be doing WD’s stress testing for them. Anyone any idea when there may be some improved firmware available?

Thank you for the solution! Worked as a charme!! I am on osx. I used JellyfiSSH in stead of PuTYY to connect to the MBL. I did not need any “hard” reset of the MBL. All the menues are now working :slight_smile:

Thanks everyone. This worked first time so I was quickly sorted and didn’t have to spend the hours so many of you did.

Thanks. I almost thought I had to return my Mybooklive, until I came across this thread. It works and I am now backing up my system with Time Machine.

Thanks.  I had the same problem and this has solved it after several wasted hours.