Access problems

Hi there,

I got myself an MBL a week ago. It’s connected to the net, visible in the Macbook and on the windows PC.

I’m able to transfer files and stream music to the connected receiver.

According to the dashboard the internet access is good.

But it’s impossible to make a connection to an I-phone or any device from outside my homenetwork. In the dashboard at remote setting i get the following error: 31550 - Internal Server Error. Please retry your last operation.

It is impossible to add a user or a share. Again from the dashboard: trying to access the users the following error appears: 32102 - Internal Server Error. Please retry your last operation On retry adding a user the next

  • 32111 - Failed to create user account. Please make sure you have the required privileges and sufficient disk space for this operation and try again.

The MBL reacts with several error messages like 33166 , 33152, 31505 device not upgraded due to internal software error at all I try.

Is there anybody who knows what to do about this?



Try pressing the reset button on the back of the MBL for 4 seconds.

Can’t see the reset button be of help. It sets the MBL to get it’s IP parameters from a DHCP server, clears one password, resets another and reboots the Linux operating system.

I would try and assist myself but I don’t have an iPhone and I’m assuming WD2GO is being used?  It may be worth setting all the remote access paramaters on the MBL and trying again.  Just incase some vital step was missed setting up remote access.

The Reset didn’t work, a factory restore  did.

After the restore everything worked like it should

Thanks and regards,


Hi Saar2003 how did you factory reset. I have just bought mybook live 2gb did the firmware update and I am getting lots of error codes when I try to add user. Think Ive bought a piece of **bleep**. Dave

try disable UPnP on your router? This will force a relay connection which as worked for me.