Help please. No windows file manager access to mycloud

I can’t access mycloud to drag and drop using windows file explorer. The User Manual says I should be able to do this.
Sometimes I can see folders in the Mydrive, but I can’t copy to them because file explorer doesn’t give me options like copy/move when it’s to the mydrive.
Sometimes I get an ‘enter network credentials’ pop-up, and no matter what password I type (Mycloud, windows, current ones, expired ones) I can’t get past it.

I’ve had the unit 6 months now and it’s been like this since new.

Back-up works and accessing the back-up files over the net or PC is OK.

Windows 8.1
mycloud [[DELETED]]

What do you see for your My Cloud when you open up File Explorer? See example image below. Are you able to provide any images?

Click on, tap or activate image to enlarge it.


Hello Cat0w,

In file explorer there are 2 options to get to mycloud.
(1) If I go to the Mycloud via This PC from the Navigation Pane then I get categories (not the original file structure) as shown.
Not a ‘public’ folder that I can drop & drag into.
I can explore the folders shown, but can’t do anything like delete, move new files in etc.

(2) If I go to the Mycloud via Network from the Navigation Pane then I get the window asking me for a password and can go no further as it rejects all attempts.

That’s the Twonky Media Server you’re seeing, I think.

For the network access, you should enter your MyCloud username and password.
Is the MyCloud set to the same windows workgroup as the PC?

I’ve never connected like this; I’ve always mapped the MyCloud (or a share) to a drive letter, using the ‘use other credentials’ option, and enter the MyCloud credentials. Then I can use the MyCloud like any other disk drive. You can only use one set of credentials, though (a windows issue).

Sometimes, file explorer just tries to be too bloody clever… I’m in favour of KISS.

Thanks cpt_paranoia,
Yes I’ve tried that, and the ‘use other credentials’ but I still get this ‘enter network credentials’ window.
The manual sort of mentions this “Attempting to open the mapped network drive prompts a new login window. Enter the My Cloud device username and password to reconnect the share, allowing it to
be accessible again (until the next reboot). For more information on this problem, see Knowledge Base Answer ID 6745.” but it won’t accept any password even the one I set up during installation.

*** FIXED ***

I managed to solve this issue.
I downloaded the ‘WD Access’ software, in that I could explore the Mycloud.
So I closed that, and looked in windows file explorer and now the folders could be seen!
At some point I got the ‘enter network password’ window again, and it wouldn’t accept my password(s) but then I just hit return with it blank (no characters entered) and it worked! (I’m sure I have tried blank in the past but this time it worked).

So the fix is either ‘WD Access’ or blank as network password, or both combined.

Thanks to those who replied and tried to help me.