Help can't get connected

I had to do an uninstall of everything WD yesterday and now when trying to set up my cloud it will not conect to using my account or any other method, I am using Mac yosemite and am at the point of throwing the cloud from a great height please someone give me a hand,

Ok give us some clues. What is happening? You click on the icon and it doesn’t see the device or what? Bit more detail would help please.

Hi there sorry, yes first off I found my drive but now it says no drive, if I log in with email and password set up previously I see the cloud drive but cant connect to it

Ok that’s a start. Can you access the dashboard? Do you know the IP address of the unit?

No on the dashboard and yes on the IP address

Ok type the IP address into your browser and you will be in the dashboard. You should be able to change settings in there then. Have you tried that?

I tried that and safari says cant connect

Ok, sorry I this sounds patronising but it’s not easy to not patronise when you know nothing of anyone’s experience levels so i will try to help now.

I am guessing you are using the app to access and not wd2go via the internet. On this basis is the IP address that you have definitely the current one or is it one you established after install? Is the IP address set as static on your router or do you have dynamical addresses? Do you have admin rights to your rioter and can you therefore determine if it is the current IP address for this unit? Safari should be access this IP address and see it if it is there.

Hey I am completely rubbish with this stuff so dont worry, I dont know much about IP or anything but I have managed to sign in to wd2go and I have an orange triangle on the left of my Cloud does that help, really sorry for being a touch dense

No no don’t ajolopise. I am ok with lots of stuff but also get bogged down from time to time. Can you tell me exactly what started all this? You mentioned I think that you did a complete uninstall is that right? What did you uninstall? Just the apps on the mac or did you perform a complete reset on the mycloud? Have you tried uninstalling the apps from the mac and then downloading them afresh? If you do this they should and that is SHOULD look for your unit on the network, find it and then all should be ok.

I did an uninstall all the apps I also did a quick reset, 

Ok, now what do you know of your router details like admin and password? You may need to get into your router to see what IP address has been assigned to the device. When you reinstalled the apps did they simply not find your device at that stage or simply stop working later?

Also, do you have another computer or iPad that you can use to see if it can access the unit? Like that we can see if it is a local issue on your mac.

they found the device just couldnt access it, it says connect remotely, I have just managed to get a screen that is asking for a username and password, it is not excepting the one I used initially but its a step closer 

on my phone and ipad it just says offline

You did a reset so I assume the access has also reset. Did you try admin/admin?

that doesn’t work, I have a a screen now that saysEnter your name and password for the server WDMyCloud but is doesnt accept my password it also gives me an option to enter as guest

Is that local access or wd2go? Can you enter as guest?

Also did you reset in the correct order? Uninstall all apps. Reset, then download all apps.

from my Mac now I can enter as guest and as for the other things Im not sure I think so