Having sent two emails to WD help/support i have yet to get a reply?? great customer service.

I have a WD My Cloud device and i am unable to access through the back end of the device to amend the user settings or add and remove users.

If i us wd2go i can only access as a user and unable to as an admin, how can i completely start from scratch as if i was just taking it out of the box?

I am not too impressed with the device so far and with the lack of response!!


Hi Chris,

Did you upgrade to Version 4.0xx  Firmware ? Seems to be some issues with this firware that WD is working on to fix.

To restore accounts and default Dashbaord Settings.

Have you tried the 40 second reset yet ?

Unplug the power to your MyCloud

Using a paperclip, press and hold the reset button on the back of the MyCloud Case.

Continue to hold reset button in and plug power back in to your MyCloud.

Still continue holding the reset button for a total of 40-50 seconds.

This will reset your MyCloud to Out of the box as far as User Accounts and default Dashboard Settings.

Once you are back in to your Dashboard You can do a Full Restore but,  This will wipe out any files and folders that you have placed on your MyCloud.

Hi YooCloud,

Thank you for your reply. 

I have tried the 40-50 second reset by powering off and on the unit and still no joy. I am unable to access the dashboard as the internet will not connect.

i have both a mac and windows machine and tried accessing the dashboard using google chrome, IE and safari with no joy. is there something im doing wrong?

Kind Regards 


Make sure the IP address of your device has not changed. Mine has a couple of times with router reboots, etc. Just look at the properties of the WDMYCLOUd in your file manager (if on Windows) in Networks.