Gen 1 wont recognize firmware update


#1

Hi Folks,

I am the happy owner of a gen 2 device, but picked up a gen 1 one for another TV on closeout at a good price. This gen 1 device came with firmware 1.01.70 which is rather old. I’d like to update it but I can’t seem to make it recognize it. I’ve downloaded the official 1.03.01 firmware for this device, unzipped it and placed it at the root of a freshly formatted usb drive and nothing. no offer to update upon power up or reboot and no icon in the settings menu. I tried HFS+ (non-journaled) and also MS-DOS formatted disks, no difference. I even tried 2 different unzip utilities in case one was causing a problem. Then I found a link here for the 1.02.07 firmware and tried that, but equally it doesn’t seem to see that either. Got a little 100meg USB thumb drive and placed the update on that and still nothing.

Is there an extra kick necessary for the really old firmware to update? I’d like to get to at least the 1.02.07 version as that seems to be stable and popular with you guys here.

Any help greatly appreciated! thank you!


#2

those FW(1.03.01) you are trying are for the GEN1 model.

the current FW for the gen 2 is version 1.01.77 you can download from

http://support.wdc.com/product/download.asp?groupid=1004&lang=en


#3

AH HA! you are correct. I was mistaking the gen1 for the non-live version and thinking the gen 2 was the networked device, but there are evidently 2 versions of this one too. It is now rebooting after having recognized this update.

Thank you!