WD TV HD Media Player (Gen 2) product update version 1.01 - 11/18/09


#1

New Firmware Update for WD TV HD Media Player (Gen 2) available at http://wdc.com/wdproducts/updates/?family=wdfwdtv_hd


#2

I think it should be made clear this is for the WD TV gen2 not the gen1.


#3

Thanks for pointing it out. The message has been edited per your suggestion.


#4

Can you please tell me the difference between Gen 1 and Gen 2? I am considering buying the WD TV Live but want to make sure that I am sold the latest version. Do you think dealers will know that there is a Gen 2 available?

Does the Gen 2 have a different product no?

Sorry for all the questions. Just want to make sure.

Andy


#5

Hi Andy, in response to your question, Gen 2 is the new version of the WD TV HD Media Player.  You can tell by the model number.  It will be a model number starting with WDBABFxxx, which will end with letters associated with the region it’s sold in. 


#6

MontySweden wrote:

Can you please tell me the difference between Gen 1 and Gen 2? I am considering buying the WD TV Live but want to make sure that I am sold the latest version. Do you think dealers will know that there is a Gen 2 available?

 

Does the Gen 2 have a different product no?

 

Sorry for all the questions. Just want to make sure.

 

Andy

Andy:

There are some minor differences between the two models. I have attached a link to the specification sheets of each drive.

This is for the Gen2

This is for the Gen1


#7

Well apart from different product number can’t see any obvious differences - anyone help?


#8

DTS support (without a receiver) is the big change at least codec wise… there were a few other differences, but nothing huge. Its essentially a WD TV Live without the network functionality.


#9

Dang update bricked my media player.  All I get now is a WD logo and nothing else.  Anyone know how I can recover my device or am I looking at buying another unit???

-JazMac


#10

I think the gen 2 turn off the USB ports…  that is the worst problem I have in my gen 1…


#11

Having used both a Gen1 and Gen2, I would have to say that the difference aren’t “minor”. Major differences include

  1. The fact the the USB drives turn off

  2. They fixed a hardware issue which caused the remote to be extremely flakey with Samsung and Philips television sets (it’s not very well documented but you can find info on the web about this)

  3. Much much faster due to the fact that they used the same sigma chip that is in the Live

  4. DTS stuff which has been mentioned

  5. File manager, which could be included in the Gen1 but hasn’t been

  6. And yes, other minor differences

For anyone reading this post trying to decide between the two (assuming the Gen1 would save you money), I’d definitely pay around 20 to 30 dollars more for a Gen2 just because it’s considerably more polished and more functional.


#12

The model I’m looking at buying is at Costco: WDTV WD Live HD Media Player, 

Model #WDBAAN000NBK-NECS.  Is this first or second generation or something else?

I am planning to connect to my network, which includes my main computer, an imac

running OSX 10.6.2.  Is this Media Player compatible?


#13

The WD TV Live Media Player is different than what we’ve been talking about in this thread.  It’s a network capable media player.


#14

i dont get it… both brochures for the product overview say that it supports DTS. i thought that was one of the features that set Gen 1 and Gen 2 apart? or have i missed something

i have a gen 1… does anyone know if WD is working on an update to support DTS decoding (without using a receiver)?

Shayne


#15

Hello everyone, I’ve got a question… up until yesterday I had the Gen1 player and worked fine except for the flakey remote. I have since purchased 2 gen 2 players. and have run into a problem,it will play some mp4s but not others. the mp4 movies that won’t play are the exact same ones on both gen 2 units, but if I hook the same hard drive back up to the gen 1 those Mp4 movies that wouldn’t play on Gen 2 will now play on gen1 like it did before…I am really confused and have been searching for an answer,any thoughts

thanks Indiana Jim


#16

IndianaJim wrote:

Hello everyone, I’ve got a question… up until yesterday I had the Gen1 player and worked fine except for the flakey remote. I have since purchased 2 gen 2 players. and have run into a problem,it will play some mp4s but not others. the mp4 movies that won’t play are the exact same ones on both gen 2 units, but if I hook the same hard drive back up to the gen 1 those Mp4 movies that wouldn’t play on Gen 2 will now play on gen1 like it did before…I am really confused and have been searching for an answer,any thoughts

thanks Indiana Jim

If I were you I would open a ticket with WD support.  Use the mediainfo program to provide them with the specs of the MP4 files.


#17

IndianaJim,

This board is for News and Announcements.  If you need further help let me know and I’ll move your post to the proper board for you.  I’m going to freeze this thread for now.