Full Factory Restore now at 62+ hours!

From what I’ve been reading, I realize it can take a long time to perform a full factory restore, but this seems to be taking a long, LONG time. Yes, it’s a 6TB drive, and I understand the process its performing (writing and reading 0s to every bit), but I’m wondering if the dashboard is giving me false information. The darkened dashboard shows a window titled “Full Factory Restore” that says “Factory restore in progress”, shows a time counter (that resets to 00:00:00 when it reaches 24 hours) and an animated cloud symbol. The “Switch to Quick” button is greyed out.

The LED on the front panel of the drive is a steady blue and has been for a day or so.

I cannot contact the drive using its last known IP address. Because of this, I’m afraid that if I shut down my computer, I won’t be able to reestablish contact with the drive (or worse, turn it into a brick).

Is this normal behavior? Is there something I can do to safely terminate this process? Help would be greatly appreciated!


Given that I get a write data rate of about 45MB/s, I’d expect a single pass write of 6TB to take 6e12/45e6 seconds. Which is about 37 hours. So multiple passes will take longer. A forced page refresh would normally cause a need to login to the dashboard, so I’m not sure what the best thing to do is…

a full factory restore is wiping all user data from the item. So I think it i needed to get the setup software from the wd learning center and then set it up again… it was mentioned that the cloud showed a steady blue light indicating the cloud is ready.

There is no need to use the “setup software” from the WD Learning Center. One can setup the My Cloud using their web browser and the My Cloud Dashboard. After initiating and completing a reset or restore one should be able to access the My Cloud via http://wdmycloud (Windows) or http://wdmycloud.local (Macintosh) with their web browser.

I sometimes read that people can not acces the dashboard, and then it might bee needed to use the setup software, because it search for the cloud, and if it is healthy it find it, and one can now change the login credentials. I use the setup soft if my cloud gives me problems with the dashboard.

First, thank you to everyone who has been kind enough to respond to this thread with their thoughts. I appreciate that very much.

UPDATE - 74+ hours and still going. At this point I’m not sure what to do. I don’t want to ruin the drive, but I can’t let it run indefinitely. If I knew I could shut down my computer (Windows 7 64-bit) without compromising the restore process, I could let the process run for a few more days.

I was under the impression that the steady blue light means the process has finished, however the dashboard counter tells me differently.

Any suggestions or insights would be appreciated.

Thank You!

PS - For the record, this is one of 5 WD network drives (2 My Book Live. 2 My Cloud & and a new My Cloud Mirror) on my network. This is the first problem I’ve had with any of them. Each has performed flawlessly over the years.

If the front panel light was blue to start with, then went out when you started the process, but went blue after some time, then I’d suggest you do a force refresh of the web page. It may be that the web page is simply not being refreshed (possibly because your router has assigned a different IP address as a result of the mycloud doing a factory restore; changing the device name, changing the network settings, etc).

What you write makes sense, Captain. The LED was steady blue before the restore process, then went out and is now steady.
I’ll try that tonight and report results. By “force refresh”, I assume you mean F5, yes?

When I access the router directly via its IP address, it shows the My Cloud drive as an attached device. It also shows that drive is using the same IP address it did before I began the restore process.
Because I have been unable to connect to the drive directly using that IP address, I assumed the drive had not yet completed the restore process. Perhaps I was mistaken.

Depends on the browser. Some require Ctrl, too. Or just close the tab and open a new one and try to access the Dashboard.

My browser is Mozilla firefox. F5 reloads the actual page, not the cached page. I’m concerned that if I close the dashboard, I won’t be able to access the drive.

Just so I’m clear on our terminology, when you say ‘dashboard’, I assume you mean the page displayed when I enter the drive’s IP address in the browser’s address bar. Am I correct?

Yeah, I can understand that… I would be too. I’ve never done a full factory restore, so I don’t know how long it should take, and the dire warnings about interrupting it don’t inspire confidence. The unbricking process is pretty well established, though… :wink:

‘Dashboard’ is what WD call the MyCloud’s control panel. Yes, it’s what you get to if you enter the device’s IP address in a web browser.


You have read the User Manual, right…?


Thank you for all your assistance, Captain, and for the links. I’ve read the manual, but it’s information is somewhat sparse on this topic. I might be able to try the F5 key in a couple hours. If so, I’ll post my results.

I also noticed yesterday that, although the button to switch to quick restore is greyed out, the button does change slightly when I mouse over it. I’m tempted to try to click on it and see what happens.

It was just that the manual uses the term ‘Dashboard’ extensively, and, since you didn’t seem sure what it was, it suggested you hadn’t read the manual. I agree that the manual is pretty sparse on detail about factory restores…

Tried F5
No change
Tried to directly access drive via IP address
unable to connect
tried ctrl+f5
this refreshed the window
instead of dashboard, window now says unable to connect
Drive doesn’t show up in Windows network (mapped connection has a red X by drive letter/name)
unable to access drive via ssa
connection refused (restore probably turned off SSA)
Drive LED is steady blue and the drive doesn’t seem to be doing anything.


Try to connect a network drive. Use browse to locate the My Cloud.


4 second reset whilst powered
40 second reset whilst applying power.

If neither those work, then it may be unbricking time…

Do you have it backed up?

if I click on the old drive letter in windows explorer, this is the message I get:

"An error occurred while connecting M: to
Microsoft Windows Network: The local device name is already in use.

The connection has not been restored"

I’m thinking I should shut everything down (computer and router) and see what happens on reboot?

Should sort out network funnies, yes.

What I meant was to try and map a new drive and use the browse to see if the My Cloud shows up.


If the Ip address was changed then the M drive would not restore.


OK. The part of the message I quoted saying “The local device name is already in use” gives me hope that it’s now a networking issue.

This is my new plan of attack:

  1. I will un-map (disconnect) the My Cloud drive in Windows Explorer. Leaving the My Cloud power on, I will shut down the PC and the router. I will power up the router first, then the PC. If I still don’t have access to the drive, I will…

  2. Try the 4-second reset. If I still can’t access the drive, I will…

  3. Turn off the power to the My Cloud. After a minute (to let anything spinning come to a complete stop), I will press the reset with my trusty paper clip, power up the drive while still holding the reset, wait 45 seconds and let it go through a system restore.

I probably won’t get to this until tomorrow afternoon, but I’ll be checking back here periodically to see if anyone has any suggestions or ideas.

As always, the help and wisdom you’ve shared is greatly appreciated.

Many Thanks!