Full Factory Reset

#1

Dumb question – how long does it normally take for a full factory reset? I have a 4TB device. I didn’t really have much set up yet on it, but due to a network problem I was having, I decided to reset it and start all over (despite my frustrations). It’s now been almost 22 hours – can this be accurate? What should I do if I have to stop it? It says, “Interrupting the factory restore process may damage the WD My Cloud device.”, so what now? It also stated, “At the end of the restore, the “Factory Restore Successful“ message displays, and the system reboots.” It still appears to be “working” stating, “Factory restore in progress.” as it continues to “count down” it’s progress. It seems a bit much, if you ask me…

Bern  :confounded:

#2

That might not be a suprising outcome, unfortunately.

I ran a full factory reset shortly after buying my 4TB, and it took ~16.5 hours.

#3

It’s now been 35+ hours and it’s starting to worry me. How long should I wait before taking action (of which I’m not even sure)? To be warned NOT to interrupt while it’s in the state of resetting is one thing, but to not know when to ‘give it up’ is another. At SOME point one has to assume that something went wrong, yeah? I’m truly stumped…

Bern  :cry:

#4

good luck with this. Everything seems to be slow with this product.

#5

My 2TB took over 24 hrs… nearly 30 as I recall… 

#6

It’s been 48 hours now with no end in sight – really? REALLY??

Anyone know if I can SAFELY shutdown, unplug or otherwise QUIT ALREADY?

Grrr…

Bern  :angry:

#7

OMG – It’s FINALLY rebooting!!! Put this one down in the record books and never EVER do it yourselves unless it’s a last resort, yeah?

I’ll be sure to let you know if it takes more than 48 hours to reboot…

Bern  :dizzy_face:

#8

SLOW!!!  I’ve had this device for 2 days and already I am of the opinion that it is ‘unfit for purpose’ and ‘not as described’.  Even from the first plugin it is slower than the USB drives on the network and has other problems that seem to have no resolution. 

For example, I tried to increase the capacity by plugging in a My Passport drive into the USB port on MyCloud.  This is suggested in the manual and would seem like a good idea - but it wasn’t.   The new drive appeared as expected - another folder on MyCloud.  However, it slowed down the My Passport drive so I decided to remove it.  The problem was that the My Passport drive continued to appear as part of the MyCloud tree and there is no way of removing it or accessing it.

Easy to deal with you might imagine since there wasn’t a great deal on the drive - reset to Factory Settings and start again…  That was almost 20 hours ago and still no sign that it will ever finish. 

There was a time when I would stake my reputation of WD products, especially for network use.  I still have a working 20 year old WD Caviar drive running Netware without a hitch so what went wrong?  In recent times this opinion has changed and this is the second time I have regretted the purchase of a WD product. 

Fortunately, I bought this one online wso I can easily return it if I remain disappointed.  Unfortunately, if that happens, it will be the last WD product I ever buy and my recommendation will be anything but WD when asked for an opinion.  Having read so many bad reviews and experiences regarding this product, my gut feeling is that I should just send it back , do some more research, maybe spend a bit more and look for something that actually works…  Most disappointed.

#9

the full factory restore is slow because it writes multiple patterns to ever sector of the disk to prevent data recovery which is only useful if you are getting rid of the device. It is a little strange how much it varies but 1-2 days seems to be “normal” for this.

the quick factory restore does the same thing as full but just deletes the data.

#10

My 4TB is still running after 48 hours + 1 hour and 15 mintues.

Absolutely horrendous experience.

The thing is though, I couldn’t hear any sound from the hard disk anymore about 2 hours ago.

It sounds like it’d stopped. But nothing’s happened apart from the elapsed time ticking away…

Seriously, it’s been almost 50 hours and it’s still running. How slow is this thing?

#11

Just finished a full factory reset on a 2TB MyCloud (before RMAing back to WD).

Took 60hours 30 minutes

#12

hi all, 

this is so embarrassing ! ( for me ? for WD ? for all ? ) 

I really hope we can save some other chaps time with these comments but I really doubt it ( I end it up here only afterwards ) thus implying directly the misleading documentation that “says” in the 1-st place

Full Restore: Reverts all settings to their default values and permanently overwrites or erases all user data and shares. It could take several hours for the process to complete.”

Waouw this is so wrong !!! I really feel stupid here several hours in my opinion does not mean 60 or 70 but rather few days in the best case ! 

So if you are lucky to read this BEFORE you hit Full Restore than be aware that the larger your WD size the more DAYS you need to wait -> so consider it carefully before you use it.

I honestly can live with the above mistake if it’s a matter of scale only ( saying several hours instead of few to many days ) but one bad thing can lead to another : "WARNING! Interrupting the factory restore process may damage the WD My Cloud device. Wait until after the reboot to use the device again."

Now in a few hours probability to interrupt is a lot lower than in few/many days … so what are we really talking about here ?! the Warning is wrong and misleading I urge WD to correct the PDF or the paper that comes with the product to include this errata.

  

#13

Guys ! 

It took 6 days ( and 4 hours ) !

( for 4GB )

#14

seems long but the only time you should ever use this is if you are getting rid of the device. It takes so long since it writes multiple pattern over the entire disk to prevent future file recovery.

A quick factory restore is the same as full factory restore but it just delets the data instead of the multiple patterns over the entire disk.

in most cases the best option is a system only restore as it leaves data and shares in place

#15

I performed a full factory restor of a 3 TB MC last night using dashboard accessed directly from Linux and Firefox. This morning I saw progress on Dashboard at 99%. A littlle while later I saw a ‘spinning wheel’ and the message was 0%. I didn’t trust this, so I closed the window and accessed dashboard again and was successfully configured it!

Factory restore succeeded

 

Your system is restored to its factory defaults.

Thursday, March 12, 2015 11:57:10 AM (this is Pacific time - my time zone is Eastern so the process took about 9 hrs)

I honestly don’t know how long the original sdashboard screen would have taken to refresh to the configur screen.

#16

It is horrible.  I stopped it right after 10 minutes.  It has change to quick mode and that’s how I stopped it.

I rather “reflash” the firmware and start over again.

#17

hi guys,
i have some questions about factory reset as well.

can i close the browser tab in which i opened the dashboard to factory reset the device? if so, can i get back in to see the progress?

and can i turn my computer off while factory resetting the device? i mean the computer and the device are not connected to each other directly after all.

#18

How is it horrible? You do realize its a 4TB drive right? It literally has to write 0’s out to every single bit on the 4TB drive, I can’t emphasis that enough 4TB Drive its obviously going to take some time.

If your unhappy just do a quick format, which rather than writing 0’s out simply marks the used sectors as overridable.

#19

It is horrible… with its name.
In most case factory reset does not mean over writing all bits.

Quick format: I would expect removing user parition data in HDD only.
Factory Reset: Remove Data + Setting

Replacing 0 should be named as secure erase.

And there is no further information from the UI to tell you all about this. Until you waited forever after clicking the factory reset button.

#20

You’re absolutely right most times with most devices that truly is not the case but most devices also don’t have an option named “Quick Restore”.

Quick Restore warns you it: does not fully overwrite or erase the drive.
Full Restore warns you it: deletes all user data and shares permanently

That said I’m truly sorry but by applying some common sense you’d think that it would elicit the fact that the latter option is going to take much much longer especially since its a 4TB drive.

“Replacing 0 should be named as secure erase.”
Naming it Secure Erase would also not really be true to its name. Although WD claims to permanently user data it only does so by means of typical consumer data recovery practices. However, If you were take the drive to a professional data recovery expert or use a higher level of data recovery software all of that data is recoverable. To me that would give off a false sense of security.