Full Factory Reset

I take it you read p84 of the user manual, that describes the three types of reset pretty clearly?

And says this:

  1. In the System Factory Restore section, click the desired type of restore: System
    Only, Quick Restore or Full Restore.
  2. When asked to confirm the action, click Yes.
  3. When the progress bar displays, if you selected Full Restore in step 1, but you change
    your mind, click Switch to Quick to start a Quick Restore from the beginning.

So you can abort a Full Restore and switch to a Quick Restore if you get bored waiting.

It is not a matter of documentation. As a big tech company, they should have some common sense.
Who the hell want to wait like 10 hours to factory reset a unit and it is even not a “secure erase”?
Would you found it reasonable to get on a bus to your next town but the bus with route through 10 other countries before reaching your destination? Could it be reasonable if it publish the route detail at the footnote of page 84 of the company website?

I’m not trying to give you a hard time I really do get what your saying. But doing a full format does have its benefits. For instance, It forces the Hard Drive to go out and read/write to every sector on the drive. This sort of action is great for detecting bad blocks/sectors a the drive. It lets the drive know that one exists and the drive reallocates to a spare sector in order to continue functioning properly. This is especially important since WD NAS’s / Personal Clouds all run on a raid array (don’t ask me why). Remember all its takes is ONE bad sector/block to break an array.

Then WD should make it a separate function named as health check or full disk scan.
I know traveling around the world has benefit but it doesn’t have to occur when I want to reach the next door.
Face the reality. Which of the best selling consumer grade NAS (Qxxx and Sxxxxxx) will do the “Factory Reset” in this way?
All in all, bad terminology and implementation.

Well I bought 3TB version about a month age, work out of the box … no way.
Constantly tried different things to get thumbnails to show, even contacted support who said "It’s faulty, send it back " !
After a lot of searching someone suggested a full restore, this solved the problem, but it seems the manual
is not a comprehensive guide to this piece of kit

Of course it’s a matter of documentation, and users not reading it.

The user interface offers three choices. It says it will take some time to do the full factory restore (which, BTW, is likely to be secure enough so that nobody but the likes of NSA will be able to recover data from it). It gives you the choice of dropping back to the quick method.

If you’re disposing of your mycloud, or returning it for RMA, if you’re sensible, you’ll do an overwrite erase, which is what the Full Factory restore is for. That erasure, on ANY 4TB disk, is going to take some time. I’m happy to wait for that length of time if I want to permanently destroy the data on the disk. If all I want to do is clear it down so I can use it again, I’ll do a quick factory restore, which just wipes the settings and disk indexing.

If you CBA to read the documentation, which is quite well indexed, then don’t complain if you make mistakes when driving the thing.

Would you found it reasonable to get on a bus to your next town but the bus with route through 10 other countries before reaching your destination?

Would you get on the first bus you saw without looking at the route map and timetable…?

1 Like

I got my WD My Cloud 3 Tb a couple of weeks ago… After playing with it for a little while and learning a few dos and don’ts I decided to restore it to factory settings and start again. The problem I run into is that after the reset WD Smartware Pro indicates a total of 2.7 Tb on the drive and 2.2 Tb available. Why the discrepancy? I’d figure that the total and available space would be identical after a restore.

I’m now trying again. I started the full system restore last night. Thirteen hours later it is 96% complete, so I’m getting better results than others are seeing. After the restore completes I plan on disconnecting the drive, removing all WD software and performing a Windows system restore to take return my computer to the configuration it was in prior to installing the drive. Hopefully this should do the trick for me.

Ok, I know this is a very old thread, but…

I just picked up a used 2TB My Cloud. When I started to set it up, I saw that there were some existing shares. So, what the heck, factory reset seemed the best option to me.

108 hours later, I still haves the spinning wheel.

What are my options now that do not destroy the drive?

Thanks for any and all help.

There’s always some default share folders.
The shares below is the default shares.
You can delete the shares, if you want to.
A full factory reset isn’t needed if you just want the folders gone.


The best option would be to wait.

I reset my 4 TB single drive mycloud yesterday, it took around 6 - 7 hours.
It mostly depends on what you got on the drive.
The more files you got, the longer time it uses.

Thanks for the reply.

Currently at 134 hours for an empty 2TB and still going.

Appears the button to “switch to quick” is not active. At least the mouse cursor does not change when I hover over it.

At what point do I give up and how do I give up safely so I can recover it. If I recover it, do I have to do the factory restore again?

What happens if I close the browser window it’s running in?

What i would suggest isn’t the safest way, but it’s atleast the only option i can give other than filling a return form.

  1. Take out the power from the back of the machine.
  2. Plug it in, you will see it blinking for a while.
  3. Once it’s steady blue go to dashboard on your device.
  4. Hit Qick recover,
  5. Wait until it’s steady blue again
    6.Then go into the dashboard and set it up again.
  6. Then do a full recover. (may take hours)

Non of the options over, requires that the browser window is running.

  1. Last option fill out a form, to return it.

I have now been waiting for 144 hours, and that orange light remains set on my mirrored 1TB drive (probably around 60% of space is used on the drive) - when I put my hand on the unit there does appear to be something going on - i.e. slight vibration. I am just hoping it will complete before I have to move premises in about a week. I am anxious about whether this is all going to pay off. Why can’t the application on the drive emit occasional progress information via email - totally dumb.

Hey guys,

I have the WD My Cloud EX2 Ultra in a 20tb…I’m getting worried to see you guys are saying nearly 2 days for a full restore on a 4tb alone…does anyone know how many days it takes for a 20tb to factory reset?

T.I.A :ok_hand:t3:

Also mine has remained idle on 0% progress for the past couple of hours now and the hard drive isn’t blinking yet…is this normal?

1 Like

Mine is doing the same ■■■■ thing. I have received no warnings about not interrupting as described in this thread, it instead just sits at 0%. After leaving it there for hours I hit the “Switch to Quick” button, and then it just sits there for hours doing nothing. I am happy I am factory resetting this thing because I’ve upgraded to a Synology and I’m getting rid of it … I will not ever be buying a WD NAS again with all the stupid problems like this one.

1 Like

I made two mistakes.

  1. Buying this sack of S**t in the first place. Its slow difficult to use and generally disappointing.
  2. Full factory reset. It is still working on it 6 Days 1 Hour latter. I know its a full restore and wipe but over 6 days for 4Tb, You are having a laugh. If it takes much longer i am going to take it in the garage and club it to death like a baby seal.
1 Like

Hi everyone, seeing what others have gone through and having made the mistake myself, I’m not going to complain but I did the full factory reset on a 4TB mycloud 7 days ago and it’s still going on (supposedly). I would love to ask you guys - some of you seem to know quite well about these things- about how one knows if the process is still going on. I can’t access to the window on the browser so I can’t see the process bar and not sure if the wifi is playing around to, which I’m my mind could be one of the problems… the Lighty is si slowly blinking as if it standby… any suggestion?
Or is anybody from WD here who could share some info on this, please?
Thank you!

I just started a Quick Factory Restore. The blue LED is fading in and out slowly. Is that what it should be doing? I thought that meant it was in the sleep mode.

Somehow, in the two long years of COVID since I posted this, I forgot what a headache WD was and bought a PR4100. It all came flooding back very quickly.

Thankfully I discovered you can run TrueNAS on these instead of this awful WD software. I’m happily running TrueNAS 12.0-U6 from an external USB3 SATA SSD RAID-1 and have never loved a piece of WD hardware as much as I love this thing now.