Ftps or sftp

Is there a way to use ftps or sftp on the dl4100?
I’ve tried to use Webdev but it keeps giving an error (forbidden access) even on the public share, I have upnp enabled on my router, ftp, and ssh work fine, any ideas
firmware version 2.11.140
thanks

Hi, I have used WinSCP to connect to a drive using SSH and be able to move files around. As long as you have forwarded port 22 and now you public IP address it should work.

… and set a very uneasy to guess password!

ok, so i have used winscp, it works perfectly, but i can only use the sshd user. I went through the ftp configuration in the network settings, however once i select Explicit TLS or Implicit TLS, i also enabled the ftp port forwarding options, i get an error when connecting through using filezilla (Server sent passive reply with unroutable address. Using server address instead) and i can not access it, i have seen other posts with the same problem but i don’t understand to they are solved!

So I enabled Report external IP in PASV mode in the ftp configuration
FileZilla give the following error after the MLSD command

Error: GnuTLS error -15: An unexpected TLS packet was received.
Error: Transfer connection interrupted: ECONNABORTED - Connection aborted

using ftptest website i get the following:

Warning: The entered address does not resolve to an IPv6 address.
Status: Connected, waiting for welcome message…
Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Reply: 220-You are user number 1 of 10 allowed.
Reply: 220-Local time is now 13:52. Server port: 21.
Reply: 220-IPv6 connections are also welcome on this server.
Reply: 220 You will be disconnected after 60 seconds of inactivity.
Command: CLNT https://ftptest.net on behalf of ...
Reply: 530 You aren’t logged in
Command: AUTH TLS
Reply: 234 AUTH TLS OK.
Status: Performing TLS handshake…
Status: TLS handshake successful, verifying certificate…
Command: USER test
Reply: 331 User test OK. Password required
Command: PASS *****
Reply: 230 OK. Current restricted directory is /
Command: SYST
Reply: 215 UNIX Type: L8
Command: FEAT
Reply: 211-Extensions supported:
Reply: EPRT
Reply: IDLE
Reply: MDTM
Reply: SIZE
Reply: REST STREAM
Reply: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Reply: MLSD
Reply: ESTP
Reply: PASV
Reply: EPSV
Reply: SPSV
Reply: ESTA
Reply: AUTH TLS
Reply: PBSZ
Error: Carriage return without line feed received

in the results box

The replies sent by your server are violating the FTP specifications.
You have to upgrade to a proper server.

Winscp error:

Can’t establish TLS connection
Could not retrieve directory listing

Any Ideas!

I am getting the same error With my Own DL4100, with a properly configured network and ports forwarded. WD support claims it is a third party software issue, but according to all the research I can dig up on TLS error -15, it is strictly a server related issue, possibly with not properly closing an SSL session from what I gather

I solved my problem by enabling the service on my router, i set port forwarding rules on the router itself and not on the DL4100, make sure to forward the ftp port and the passive ones[ default (55536~55663)].
I am currently using cyberduck client, because I had a problem with the other clients decoding unusual characters!