Help needed! wd ex2100 ftp errors

Hey guys, I just got my new MyCloud EX2100, I assume I t’s pretty similar to EX2. First, I changed the settings on my Apple router, such as port mapping etc. But when I was trying to access this in outside of my home network ( I was testing it on another PC) using FileZilla, it gave me errors like:

Connection established, waiting for welcome message…

Response:     220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

Response:     220-You are user number 2 of 5 allowed.

Response:     220-Local time is now 17:13. Server port: 21.

Response:     220-IPv6 connections are also welcome on this server.

Response:     220 You will be disconnected after 10 minutes of inactivity.

Command:    AUTH TLS

Response:     234 AUTH TLS OK.

Status:           Initializing TLS…

Error:             GnuTLS error -110: The TLS connection was non-properly terminated.

Status:           Server did not properly shut down TLS connection

Error:             Could not connect to server

However, it works perfecly fine when I tried on a local PC.

PLEASE HELP,

Thanks a lot guys

Tom

Tom,

First, you posted your issue about EX2100 in the forum for EX2. The EX2100 issues should be posted in the My Cloud Expert Series forum (meant for the EX2100 and EX4100 products) ->  http://community.wd.com/t5/My-Cloud-Expert-Series/bd-p/mycloud_exseries

Having said that, I do not know what port mapping settings you did since you didn’t elaborate but I highly suspect you only forwarded port 21. You also need to configure a passive port range from the EX2100’s dashboard (I don’t have an EX2100 but I’m guessing the ftp config settings are similar to my EX2’s settings). From the same place where you configured the ftp port, the next screen of that configuration should present you a range of ports for passive mode. All you have to do is on your router forward the ports for that port range to the same IP as you did for port 21. And be aware, when you do this your ftp access will break when using ftp from within the network - i.e. if you use EX2100’s internal IP. The solution is simple - just use your external (WAN) IP even when trying to access by ftp from inside the network.

This question has been asked here several times and have been answered here before. Please do a search before posting as you’ll likely come across the same issue and its solution without even having to post.

Please click the star on the left under my username to give me a kudo and mark this post as the solution if my suggested solution works, so that future community users can benefit from this.

Hey,
Thanks so much for your reply, I’m very certain that I have forwarded passive port range to my EX2100’s on my router. But it still doesn’t work.

I have seen this very error before and the only fix was the missing passive port range forwarding. If you have set it up correctly then you shouldn’t be getting this error. You can post a screenshot here of all your port forwardings if you like and I can check to see it looks okay (just black out your WAN IP…and show only the LAN IP to protect yourself).

That’ll be super helpful, thanks,

I set Network to Static, and made a reservation in the router for that specific one, then configured FTP stings, passive mode port from 55530 to 55659 then Explicit TLS.

I only added three port mappings

First one

Second one

Third one

Don’t know what else should i add now.

Thanks 

I reinsert those pictures

I am unable to see the pics. The mods approve any posted pics ad until they approve the pics they only appear to the poster but not to others. Unfortunately sometimes they can be slow to approve pics. They will also not approve any pics where your external (WAN) IP is displayed, to protect your security. I hope these pics had your WAN IP redacted before you posted them.

If you did, I don’t know what’s the hold up then. Sometimes I am very frustrated with the mods here who don’t seem to be very quick on the foot on pic approvals. Sometimes some of them can’t differentiate between lan and WAN IPs and they decide to hold back the images despite the pics only showing LAN IPs. That is why I usually upload to imgur.com and post a link here as well as posting a pic, so that others can view the pics at an alternate location by the time the mods decide to wake up and approve the pics.

Ok, I can now see them. The settings look correct…except I don’t know what you are doing with the port 990…not sure of that one’s purpose, but even that one looks like it is forwarded correctly (as long as your EX2100’s lan IP 10.0.1.106 is accurate). I have different numbers for my ftp setup’s port range, but that may be because I may have chosen a custom range rather than use the dashboard generated ones.

My most important questions are after seeing this - do you not have a router that your Internet provider gave you? If so, have you done the same forwardings there first and forwarded the traffic to the Airport’s IP (if you are using the Airport in NAT mode - but if you are using the Airport in bridge mode then these settings need to be made ONLY on that router)?

The idea is very simple. With port forwardings you are telling the data packets to go somewhere when they arrive on a certain port (i.e. you are forwarding them). So if your ISP’s router has not been setup yet, how would the ISP router know to send the packets to your Airport router? Normally the data from outside first lands on one’s ISP’s router and then goes on from there.

Please click the star on the left under my username to give me a kudo and mark this post as the solution if my suggested solution works, so that future community users can benefit from this.

1 Like