Folders Within Public Share Read-Only after Firmware Update

A few folders within my Public Share have suddenly become Read-Only after the last firmware update.

-I cannot write / delete or do any action to the affected folders.I get a “Destination Folder Access Denied” error. (Screenshot attached). I can read the files and the movies/music is streaming fine to my TV etc.

-This has not affected all the folder, just a few of them and I don’t know whats common among the folders that are having this problem. (Screenshot attached, the folders marked in black lines are the ones affected)

-I also did a Systems Only Reset and that didn’t seem to have helped.

  • I can create new folders within the public share and they work fine

Please help! The biggest data dump in that folder called unsorted and I don’t even have space to back that up somewhere else.

Thanks In Advance

Hi

My first time here and like you, I am looking for the same answer.  After the firmware update, I also found I could no longer add, delete or move files from certain folders whilst having no issues creating and using new folders.  I get the exact same message about permission.

I thought it may be a Windows folder access issue, but I have access to some folders, just not all like before the firmware update.  It has been incredible frustrating trying to resolve this and I have yet to do so - just a work around for the time being.  My first time with such a product (chose WD as I always use their HDs). but I am left disappointed having used the product for months without issue.

I am hoping a new firmware will update will resolve it, but for now I cannot even revert to a previous firmware.

For your information, my workaround was to download WD My Cloud app (software version 1.0.7.5) and use that to copy or move files to the folders having issues, but be warned, it’s incredible slow.

Hope this helps as a temporary measure until WD resolve it.

It would be nice to know what the file permissions are for those directories in the Public share.  Post the results of ls -l.  ssh into the WD My Cloud.  cd to the public directory.  Type ls -l and post the results.

We need to know if the permissions have been modified or not.  Doing a firmware upgrade should not change permissions.

What could change is the samba configuration.

RAC

having the same issues here…

have 5 folders in volumes/public/

these are 3D, Boxsets, Films, Training and TV series

when trying to create a media library on  both my WDTVLive SMP’s, i get the read only message on films, training and TV series folders, but only when using the windows share option… when using Mac Shares, they all integrate into the media library… i dont get whats going on? and this is since the update last wednesday 

My suggestion (and it’s only that) would be to disconnect the mapped drive under Windows, and then re-connect, giving the appropriate user and password (use the ‘connect as different user’ option).

Same issue here. I updated the firmware last week and now, all of the Windows users here in the office report they can’t save files, spreadheets, updates, word documents, etc on the MyCloud. A Permissions error message pops up. Save As doesn’t work either. This is all through Windows explorer.

Trying to use the MyCloud App on the Windows machines also doesn’t work. We can see and open files, but can’t save any changes.

Funny thing is, for the Mac users, they’re not having any issues. I can see the MyCloud through my Finder, access all files/folders, open, edit, and save documents with no problems.

Any help with this Permissions issue would be greatly appreciated.

Hello,

We have passed this along to support.

2 Likes

Many thanks for passing this onto support.

I’ll look in from time to time for any updates.

I had raised a ticket and I got a call from the support and they asked for system log, which I have sent. Still no resolution. Anybody else dealt with the support team already?

Did the Linux or Samba permissions change.

To check Linux

  • enable ssh
  • login using putty.exe or something
  • run the ls -la command on parent folder having the issue

ls -la /shares/Public/
total 28
drwxrwxrwx+  6 root  share 4096 Sep 16 20:31 .
drwxrwxr-x  12 root  share 4096 Sep 13 10:08 …
drwxrwxr-x   2 root  share 4096 Sep 16 20:31 Shared Music
drwxrwxr-x   2 root  share 4096 Sep 16 20:31 Shared Pictures
drwxrwxr-x   2 root  share 4096 Sep 16 20:31 Shared Videos
drwxrwxr-x   4 admin share 4096 Sep  6 21:56 Virtual Machines  <-- Admin user created this share

I have the same problem following latest firmware update.

My public share is fine, but all other shares set as public give me this same error.

The root of those folders seem to be ok, but I can’t copy files to any subfolders.

Do support have any update on this?

It’s an unacceptable situation and is causing me major problems.

Missing or disturbed shares after firmware update sounds a bit like this:

http://websupport.wdc.com/newSupport/KnowledgeBase/answer.aspx?ID=13161

System-only restore is the recommended fix.

I’ve got this same problem after the latest firmware.

A system restore did not resolve the issue.

Really frustrating not being able to use my drive as intended.

Hope the support team gets their act together quickly to fix this issue!!

1 Like

 Same problem for me. A huge shame for WD.

I let the automatic update paramter ON until the correction and after that, bye bye.

It’s absolutely inaccpetable, I cannot use the PUBLIC folder as I want : who is the owner of my WDCloud ? WD or me ?

[[DELETED]] 

**bleep** i n g waste of time, energy, business.

[[DELETED]] programmer ! And you, the **bleep** i n g WD quality control manager! 

How is it possible? Go and find a job with WolskWagen: this is the place for applications that lies to users.

At least it shows us we do should not place our confidence in WD. 

WOO! HOO!

Got a call back from support yesterday evening.

Remote session, they installed a patch and BOOM!! I can write to all of my Public folders again.

Call support, ask to be escalated and then ask for the patch to fix wrting in Public folders.

happen to still have the patch file?

all my public folders and files are read only right now and I need this fixed.  Or maybe a mod can post the patch on the forums for people to download so we don’t have to bother support.

All of you experiencing permissions issues, please make sure that you have updated to the most recent firmware update,

Firmware Release 4.04.00-308 (9/28/2015). 

  • Resolved issue of unable to create new folders or write to folders after firmware update 

http://support.wd.com/downloads.aspx?g=904

Did the upgrade an hour or two ago and it didn’t resolve anything. Disappointing…

I also updated to latest firmware. Resolved nothing!