Folders missing from myCloud


I have some folders that suddenly are not visible via my Samsung TV, they used to be visible.  I do not remember changing any settings/permissions.  I have done a complete database rebuild via the myCloud UI and not via Twonky.  I can see the folders using Windows File Explorer just not through the TV.  Any suggestions?

Thanks in advance


Rebuild Twonky db http://wdmycloud:9000/rpc/rebuild … Refresh the browser if it doesn’t redirect back to Twonky’s page (Twonky restarting).

Wait till the scanning process status completes then restart your TV.

Problem half solved…  the missing folder is now visible, however I have added files and they are not visible. I have the rescan set at “-1”.  Why aren’t new files/media visible?


Does anyone else have this problem?  Very frustrating.  The files are there I can see them via File Explorer, however my TV can’t see them.

Hi Rudy,

This sounds similar to my problem.

Maybe you could try to move a file into the root of the shared folder.

I hope we get solutions soon :slight_smile:

Hi, still no help from WD.  Surely I am not the only person with this issue??  So frustrating!

Did you contact WD support? This is a user to user support forum provided by WD and we try to help the best we can.

keep in mind there are several different ways to access files on the my cloud. in this case you are looking at a DLNA/twonky issue

In this case it sounds like some files show and some don’t so it sounds like media serving is setup ok

are the missing files the same extension and encoding as the visable ones? My dish hopper is extremly critical about what it shows.

try to rescan in the twonky settings, http:/mycloudIP:9000 there is also setting in here that you can choose the type of player which may help