My files and folders can no longer be seen on my TV

I have my MyCloud connected to my Panasonic TV via VierraLink. It has worked fine ever since I’ve had it. All of a sudden, I can see the drive itself, but when I click on it on my TV to go to my files, i.e. Movies and TV Shows folder, it’s not seeing anything. Nothing has changed except I downloaded the latest version of MYCloud Dashboard as prompted to when I launched it.

I can see the contents on my iMac and on my MacBook as I did before, but it’s just on the TV.

I also cannot seem to connect WDMyCloud-Dashboard anymore, it just times out saying can’t find.

Any ideas anyone?

I’ve reset it and managed to get into the set up via the web (not the Dashboard program). It appears an automatic Firmwire update was done on Sunday. This has got to be the problem I reckon. Can I go back with firmware?

Check that your device’s IP address hasn’t changed; if you’re using DHCP, and the device reboots, your router may re-assign the IP address. This can cause problems for networking.

I assume you’re using the DLNA Media Server in the MyCloud to access your media on the TV, rather than a network file server. If so, you need to make sure that the Media Server is running, and that it is looking in the right place for media. Both of these settings can be mangled by firmware upgrades.

I’d also go through the process of connecting your TV to your network; there’s probably a setup required to connect to a file or media server.

And yes, you can revert to earlier firmware versions: search for threads on ‘downgrade’.

Hi, I’m not using a DLNA Media Server, I’m using the inbuilt system in the TV which basically, plug it in and it works. I’ve done the same with my previous 2 NAS drives and all worked fine.

I continued trying after it getting very frustrating. I managed to download the set up installer as if it was a
new drive, go through that process. That would then let me rebuild the system file. I did that, then Dashboard would launch. I went back to the TV and I could see my files again. It must have been a corrupted system

It’s unusual (but not impossible) for TVs to have network file sever clients, but far more usual for them to have DLNA media server clients. So you’re probably seeing the Twonky DLNA media server running on the MyCloud.

Anyway, you have it running again, which is what matters…

Which option are you selecting on the Panasonic TV’s Viera menu? The file sharing Play Back function or the file sharing DLNA function?

Panasonic - What is Home Networking

If you select the DLNA function within Viera then you’ll use the TV’s DLNA client to access the My Cloud. When doing so not all folder and files will be seen. What content is shown is dependent on the supported media files for the Twonky Media Server embedded within the My Cloud. While the following WD Support document doesn’t specifically mention the My Cloud the supported media should be the same or similar on the My Cloud.

If you select the File Sharing Play Back option in Viera then you should be able to access any public or private Shares on the My Cloud.

Edit to add: It is possible that if you manually configured the Viera settings on the TV to use the My Cloud IP address that the IP address changed when the My Cloud rebooted after the firmware upgrade. If this is the case you may have to edit the Viera settings to reflect the new My Cloud IP address. If this happen the solution is to configure the My Cloud for a static IP address either within the router’s DHCP server or within the My Cloud Dashboard.

I have a related, but different question/problem.

Background: WD just provided me with a MYCloud Mirror to replace a defective MYCloud unit. All folders/shares and users have now been replicated on the MYCloud Mirror.

I can see everything on the MYCloud Mirror when I access using my computer and/or smartphone. I am now trying to view media (.jpg, mp4) files on my Panasonic Viera TV. I can connect to my MYCloud Mirror and I can see folders/shares on my TV. However, I only see roughly 20% of what is on MYCloud Mirror (I have scrolled up/down on the TV). In other words, I cannot see approx. 80% of the files/shares despite the fact that they have the same media file types. The WD Helpdesk tells me that it is a TV DLNA limitation but that does not appear to be the case. Everything worked well with my previous MYCloud.

Since I can see some folders/shares, DLNA and media streaming settings on MYCloud are obviously enabled. User settings permit read/write access. I have tried to change user settings settings with no change. I have tried to change shares/folders from private to public with no change.
If it means anything, I can see folders/shares on the TV in the same order as they appear on my computer/smartphone but they stop at the 64th folder/share (i.e. folders/shares that are visible on the TV are not random)

Has anybody else encountered this? Suggestions?

You may want to search through the dedicated My Cloud Mirror subforum if you haven’t already to see if there are similar past discussions that may apply to your issue.

Make sure the ‘Media Receiver Type’ is set correctly in the Twonky UI.

Thanks for the input. I have searched the My Cloud Mirror community with no luck. However, reference to the Twonky DLNA media server embedded in the device opened the door to a discussion with a very knowledgeable WD Level 2 support person who was able to help me resolve the problem.
In short, there is a limit to the folders that the Twonky DLNA media server will show but that limit can be easily over-riden as long as you want to manually add the additional folders via the “settings” tab on the Twonky media server. The key point here is to get to level 2 WD IT support

This might help (if you have a Gen1 device):