Can't access files on WD Mycloud via non-WD applications


I currently use a WDMycloud 3 TB device. I have it linked to my WIFI router and then via my network I use it on an LG smart TV and sometimes through my Xbox 1. I am easily to access media on my TV or xbox.

A few days ago an electrician came out to my house and he switched off the power. Since after his trip it shows my device on my TV and console however it is blank and shows that there is no media on my WDMycloud device. When I access my device via my WD smartphone app or via the WD web portal or explorer via my macbook it shows that all the files are there and I can stream them but on my TV and console its blank.

Is there a solution for this?

Have you accessed the My Cloud Dashboard and instructed the device to rebuild the media database? Sometimes that fixes the Twonky DLNA media server issues. See Dashboard > Settings > Media > DLNA Media Server > Rebuild. Or access the Twonky administration screen (http://wdmycloud:9000) and hit the Rescan content folders button on the Advanced page.

Thanks for the help mate.

Unfortunately I did and it doesn’t work. The weird thing is in the wonky server it says that there is literally nothing on my drive, however, in my explorer all the files are there. So weird!

Access the My Cloud Dashboard and check the Shares where the media is stored and ensure Media Serving is enabled for each Share. Also ensure Media Streaming is enabled under Dashboard > Setting > Media > Media Streaming. If the option View Media Players link is available to the right of the Media Streaming option, one can select the link and view the various media players that are connected to the media server and enable or disable their access.

If you still have problems there are a few more things to try, and while it probably won’t fix this particular issue you are experiencing, they are some of the troubleshooting steps one should take when troubleshooting. First is to assign a static IP address (or reserve an IP address) to the My Cloud if one hasn’t been assigned to it already through the router’s administration interface. Second, turn off everything on the local network including the TV and XBox and wait five to ten minutes. Then power on the router, wait for it to properly boot up, then power on the My Cloud and wait till it displays a blue LED on the front of the unit, then power on the rest of the devices, TV, XBox devices. Then see if the TV/XBox can access the media on the My Cloud.

Hi thanks for the advice. I honestly tried all of your suggestions above, and it still doesn’t work. I think there must be some hardware damage or something.

Is there a way to just format and restore the device to factory settings?

There are several restore/reset options including completely erasing all user data. First try a 40 second system restore using the reset button on the back of the My Cloud, as detailed in the following WD Support Document. This 40 second system restore does not affect user data, just resets most of the My Cloud Dashboard settings to default.

If that fails to work then one could access the My Cloud Dashboard > Settings > Utilities page > System Factory Restore > Quick Restore. Quick Restore just deletes your user data and resets the My Cloud to default. The Full Restore option will securely erase the user data (which can take many hours) and resets the My Cloud to default.

Hi, I took your advice and did the system restore (without deleting date) and it fixed the problem. Thank you for the help!