My Samsung Smart TV does not recognize any folders or files on MyCloud

Hi everyone,

I have read some posts that are kind of similar, but I haven’t found any that is exactly the same. I have tried a few things as suggested in other posts, but nothing helped.

The WD MyCloud is connected to a Samsung Smart TV, and it is recognised as an external devise, but when accessing it on the TV no folders or files are shown/recognized. I don’t know where to fix this.
Also, the WD My Could Dashboard is not working anymore.
Could this be an issue with the recent update to Windows 10?
Any help would be appreciated.


How is the My Cloud “connected to a Samsung Smart TV”? Is it directly connected? If so how?

Are your media files in a folder that has Media Serving enabled?

As other threads have indicated certain Samsung TV’s apparently have certain problems accessing the media served up by the Twonky DLNA media server embedded within the My Cloud.

Hi Bennor,

It is connected with a ethernet cable, directly connected. Media Serving should be on. I can’t access the Dashboard to double check. Also, when I open the WD MyCloud app has a certificate that is expired or something. Could it be that has something to do with it?

With the Twonky, how can I access or change the settings?

What does “directly connected” mean? Is the My Cloud Ethernet cable connected to your network router/gateway? Or is that My Cloud Ethernet cable connected to the Samsung TV?

The My Cloud should be connected directly to the network router/gateway, not the Samsung TV.

I have a similar problem. Until yesterday, I had not any problem with my Samsung UE40H6500 and WDMyCloud device. Suddenly the TV cannot access or “see” any file in the WD device. However, I have full access via my PCs and tablet. It seems that all the shared folders in DLNA have 0 files. I tried to rebuild it, but nothing. Additionally, I tried to restart the twonky server and the problem remains.

PS. The firmware of all devices is updated.

Continuing the discussion from My Samsung Smart TV does not recognize any folders or files on MyCloud:

Hello to all,
I too have this problem with MyCloud and my Samsung Smart TVs.
The TVs are Wi-Fi connected and recognise the MyCloud. However they both say “no files (music ,video, or photo) file found on the connected device”.
On the MyCloud Dashboard-Media DLNA Steaming On- shows 0 music, photo, video files. I do a Rescan and nothing changes. I do a Rebuild and all the files load up. However when they are fully loaded, they then simply unload and return to 0.
I have reset the MyCloud with a paperclip (holding it in for 40 seconds and then allowing the MyCloud 10 minutes to settle) as advised by the WD technician, but to no avail.
I’m am running a desktop PC with Windows 10 and can access all the files from the PC.
I do note however that there is no “Media Server” shown under “Network” on the PC, which I do believe was previously there.
Any assistance would be much appreciated.

Have you read the Twonky DLNA Media Server Setup & Use thread posted directly above your post? Is the media you have copied to the My Cloud in a Twonky supported media format? See the My Cloud User Manual ( for the supported Twonky DLNA Media Server file formats. Is Media Serving turned on for the Share where the media files are located?

I have a new Samsung SUHD TV and have absolutely no problems with DLNA. Each of my videos are in different folders (movies, family, TV shows) and they all show on the Samsung. I did nothing special except enable DLNA on the MyCloud.

Make sure that media serving is enabled on the share containing your media AND that media streaming is enabled; both controls need to be set. See the Twonky FAQ in my earlier post.

Cheers thanks folks.

It seems that the problem is that updating the WD My Cloud DB
You need to sign in into your WD Mycloud BookLive -> setting -> media -> Twonky
check that the flag is set and update the DB -> this will scan the entire DB and all media files will be recognized. I did it and this works.
David form Israel

To update the DB, you need to click on re-build