First of the 3 blue Lights Blinking on EX2Ultra 2-bay NAS

#1

So I don’t know exactly what is going on here but as of late I have had no way of accessing my NAS outside of my home network at all. My understanding is this light is the “Hibernating light” or maybe not I’m really not sure anymore but for some reason I am constantly having to “disconnect the cloud service” and reconnect it to get it to accept connections outside of my home network service. And that’s just not acceptable the point of having this is so I ca access files i need when I’m not in my home.

It was working for quite some time with no issues until recently I don’t want to blame the firmware update but that’s when I started having this issue. I did have an issue at some point with the whole losing power and needing to turn off the cloud to be able to connect again but I haven’t had a power outage and i’m constantly having to do it to get it to function properly anymore. Please help this is incredibly frustrating…

Adding this in so I can avoid these questions being asked. Yes I have access to the drive via File Explorer on windows 10, yes I have access to the website on my ethernet connected computer as well as the wifi connection via my phone (Both the app and the website) as soon as I disconnect the wifi from my phone I immediately get a long loading screen followed by no connection established.

#2

Hi Flokke,

There can be an Domain Name Resolution issue due to which the remote access of the device on the mobile app or through mycloud.com may not be working outside the network. You can try setting up the Google DNS in order to resolve the issue.

https://support-en.wd.com/app/answers/detail/a_id/16487

#3

Thank’s for your response I actually tried that the issue is now fixed I just forgot to update this since I spent so long trying to fix it that i forgot i posted here. Essentially what the problem was the MyCloud was trying to use Port 9091 and 9444 but my router (Even though I did a force open of the ports) would close the ports the second the MyCloud would sleep even turning that feature off after a certain amount of time the ports would close after changing the MyCloud to use port 80 and 443 it started working again with no problems so I finally got it to work.