Firmware v04.01.02-417

I can´t install new firmware. Update stopped at 10%. Im installing from folder and from internet.

Firmware V04.01.02-417? Currently the WD Support site is showing v04.04.01-112 as the latest firmware for the single drive WD My Cloud devices. Make sure to download the firmware ONLY from the WD Support site.

Yes V04.01.02-417. This is screenshot from my WD My Cloud.

Oh OK that makes sense now, you are trying to update your My Cloud which is currently on version 4.01.02-417. Have you modified (via SSH) the My Cloud in any way? What other steps have you taken? Have you tried rebooting/power cycling the My Cloud and retrying the update? Have you tried a 4 second reset via the reset button on the back of the unit? Have you tried a System Only restore from the Dashboard, Settings, Utilities section?

Do you have a USB device connected to the My Cloud? I had a problem updating the firmware
when I had a USB device connected. If you SSH into the Cloud and do a ps -eaf you might see
a process trying to umount the USB device. I ended up killing that process and the upgrade continued. You could also reboot with the USB device unplugged.


One Other thing to keep in mind is sometimes the update may take a long time, like 10 or more minutes. So it may seem like the upgrade has frozen/hung at 10% when in reality it is just performing operations in the background.

No, I don´t have connected USB to the My Cloud.

I know it.

Yes I tried rebooting and restart with restart button. I will try restore from the Dashboard but I have new My Cloud.