Firmware roll back

Good day all :confounded:

I am experiecing a new issue with Mycloud mirror 6T  

My unit keeps diconneting able to sometimes see with mycloud app sometimes not temporary  fix is usually reboot and reset device an PC to gain access through WIN7 explore as setup lasts 10-15 minutes . My issue started 2 days ago when  my unit quit showing a USB attached 1T External USB drive loaded with Data even after resetting /rebooting etc and checking a multitude of other net settings relating to Win and Router ( ASUS GIG Black Night) and trying a 1T USB powered WD my passport drive etc.  I still can not access dependably any USB atttached drives. After 12-15 hours troubleshooting and a ticket opened with WD Saturday  I discovered a firmware update rolled out on Fri 1/30/2015 at 3 AM taking the unit up to version 1.05.30 this is uber obvious due to  close   proximity to when the issue began after running smoothly for 6 months plus.

I am looking for direction on how to role back to a previous version. I have obtained the firmware zip file for 1.05.21 released the end of 10/14 but when I attempt to role back in the DASHBOARD USING THE LEASS THAN STELLAER WD INSTRUCTIONS IT FAILS REPEATADLY TO UPDATE

CAN ANYONE PROVIDE SOLID DIRECTION ON PERFORMING A ROLE BACK OF THE FIRMWARE? I have seen directions for other devices such as my cloud perso nell  but not mycloud  mirror ! Thanks in adavnce to all who reply :mansad:

Details of how to do it are  here, but I will summarise below.

Log into your MCM dashboard via your web browser of choice, and after entering your admin user name and password go to settings (from the top icon bar - the far right hand one after scrolling) and then select firware update from the settings menu on the left hand side (the last entry). From that firmware update menu, select manual update (the lowest entry on the menu, after scrolling down) and point the MCM at the update file using the “Update from file” button.

If that’s what you are following and it’s not working then I would wonder if the firmware file you have is a good one or not - can you give more details of how it fails to update - what errors etc you are getting?

Darren, Thanx Nice to get  such a quick response :laughing: I will try to be as detailed as possible about what I am/have tried please excuse me if a  bit jumbled  5+AM over 50 Y/O  frustrated.

I will start with the FIRMWARE FILE I retrievd from http://drivers.softpedia.com/get/HDD-SSD-NAS-USB-Flash/Western-Digital/ as this was a referenced as a go to site by another user in the personal cloud board which does not specifically pertain to the MyCloud Mirror device. The file I retrived is supposed to be for firmware version 1.05.21 were my DS shows I am at version1.05.30 and according to the DB the latest update occured via autoupdate(Which I have since disabled)  @

Last Update
Friday, 2015 January 30, 3:02:44 AM   

intrestingly I discoverd the disonnect issues etc not seeing my attched USB HDD  Saturday AM !!! The process I have used to attempt the Firmware are much as you have detailed I will step through them  and coresponding error( S) I indicate errors because just for poo poos and grins I retreived the current FirmwR FROM THE wd SITE AND ATTEMPTED TO REINSTALL TO RULE OUT A BAD FIRMWARE FILE FROM THE OTHER SOURCE SAME ERROR!.

 As I type this I am walking through the upgrade/downgrade process once again …

  1. I login to my dashboard vias browser

  2. I navigate to settings/firmware Update

  3. I select Update from file next to the Manual Update field

  4. I select Update from file

  5. I enter the path to the local firware file and selct it

  6. The dashboard cycles through warning etc acts as if it unzipping uploading file warninwaring warning do not power off etc

  7. 3-5 seconds responds " Upload Firmware File . FAIL   Try again .:crying_cat_face:

  8. Rinse and Repeat trying either the current version or older version obtained same response Upload Firmware File . FAIL…try number 7 !

I have a bit of supician that there may be a programtic safeguard built in to the upgrade utilty tha t prevents upgrading to anything other tha a higher level firmware to avoid inadvertent downgrades by users … NOT Sure but certanley a possibilty … Lost past this point ti red and frustrated:angry: HOPE ALL MY STEPS HAVE BEEN CLEAR AND DETAILED— got an error when posting this that some invalid HTML was removed hopefully nothing of any consequence

Your procedure looks fine, but as you say if you’ve downloaded 1.5.21 from Softpedia and it failed, but also downloading 1.5.30 from WD also failing sounds like something more suspicious. I must admit I’ve never tried to downgrade my MCM, but to my knowledge there is no software block to stop people doing so and I know of other people doing it on other WD products.

From a quick look at the download file it looks to be about the right size and format. 

One thing you could try is to reset your MCM back to defaults and then try the upgrade again. To do that, go to the dashboard, then settings and utilities. From that menu you can run a system diagnostic and also view the system logs. If they don’t yield anything useful then also there is the option for a system restore to default. That would be the next thing I would try, in case something has become corrupted. Doing that won’t touch the data on your drives, it only restores the system/dashboard settings (you will lose your users and shares set-up and have to rebuild those, plus any settings you have made on the dashboard itself). You can save and re-import the configuration of the dashboard from the same menu (just below the restore to default open) but I’d be careful of that in this case as it may just save off and restore the problem back again…

Generally though I can confirm that manual firmware upgrading usually does work. I was on the beta-test team for the 1.5 firmware version so had to upgrade that way from the beta to the stable version. But there I have to admit I’ve never personally tried a downgrade as I said.

Thank again Darren you point to some alternatived I have somewhat mulled over in my mind as next steps. jave adigostic test running on the unit right now seems very very slow. I am going to flake out for a few hours and let it complete as the sun has come up in the last hour tennacity comes at a cost at times. After dianostics complete I am goiong tpo follow the sequence of items you laid out so well and hpefully resolve the issues. I find myself having very short patience with support folks at vendors as I have more than 25 years IT experiece with the last 15 managing  tech teams tha supported more than 13k networked workstations and the server teams for a 500 server farm environment and there tech skills are scriptesd at best    I dont by any means posses the technical knowledge my staff had although  I do try to keep myself a breats of the environment and my skills on an above average level. Seven  years out of the proffesional environment no doubt has allowed my skills to diminish . Should I be able to resolve I will definetley post back as the solution may assist another who might face the same predicament Thanks again  :manwink:

System diagnostics on my MCM only takes a few moments (and comes back all-OK), so if yours is taking a long time then it’s probably indicative that something is wrong somewhere. Once it’s completed (and you’re rested up) then we can take it from there - I’ll keep an eye on the thread and see when there’s more news.

Thanks again for the follow up Darren. I killed the diagnostic ran the lesser depth versdion came bacjk ok , going to hard reset MCM again to start in dpth diag although I dont know if it will complete still no sleep , 20+ hour marathond dont work for me sny more plus serious brain damge in bIKE accident 12 years ago comma 3+ months brain fizzles lika 3270 a emulatoer on 4mb token ring network after 10-12 hours. I will hard reboot /rest MCM and start dianostic and see if it will complet and start fresh on wake up . Your help is much appreciated:robotfrustrated::mansad:

Closing this issue request for help , although I had coralated the issues I was having with a firmware update this may or may not be the case . Bottom line in my configuration I have an additional 1T USB Green Drive hanging off the MCM via USB. After following up with WD support and the fact that the MCM would not complete the full diagnostice I was quickly instructed to RMA the unit ,my presumption is the USB port hardware may have failed. The fun of RMA find somewhere to offload 3 Terrabytes of data and reconfigure applications tha acessthe NAS for their datbases etc :manmad:

special thanks goes out to Darren for his deligence in offering potential solutions:laughing:

You’re welcome - I hope the replacement box resolves the issue for you.