Firmware stuck on 2.12.144 can't upgrade MyCloud Mirror Gen 2

I have searched and tried everything on the support sites and in these forums that I could find and I can’t “make the transition” to MyCloud OS 5. My 4TB x2 RAID 1 MyCloud Mirror Gen 2 says my firmware is up to date at 2.12.144… I have tried downloading the 2.41 update required before transitioning to MyCloud OS5, but the manual update looks like it’s going through the process of downloading and then gives me the error of “Upload firmware failed. Try again.” Many tries, to no avail.

Although it was an onerous task to get to (and I found no other “older firmware downloads”), I found “WD Cloud Mirror Gen2 GPL Source Code” on this page: https://support-en.wd.com/app/products/product-detail/p/137#WD_downloads

I tried to use those files as “incremental” firmware updates to manually install and I get the same error. They are tar,gz files, not .bin files like the 2.41 firmware download. I can’t fina any other “incremental” updates to get to 2.41 anywhere on WD’s site, so I don’t know what else to try.

I don’t know how to make the transition if I can’t update. This unit was virtually bricked at one point in a firmware update two years ago and I thought that it was all over for the disk and it sat unplugged for months. It didn’t work after being unplugged for a week… two weeks… but to try to tinker with it again, it actually worked after being unplugged for at least six months, if not more. I have no idea what changed between attempted boots, but, finally I had all blue lights and was able to connect. Don’t know if it’s related, but I thought I’d mention it. Dashboard disks reports/scans are all “healthy,” etc.

My PR4100 update went fine. This thing, though… I can’t crack the magical mystery of the required updates. Please help!

I have the exact same device (except ever being bricked) and exact same problem with upgrade to 2.41.121

I tried everything you had mentioned here; incremental upgrades, I even changed browsers, also I tried to upload the firmware to the NAS itself and try the upgrade from there… Nothing!

Several tries and this is what I always get: “Upload firmware failed. Try again.

Anyone from support or experienced user that can provide any guidance here please?

I hope someone helps us. It’s been so frustrating to get those doomsday emails and not be able to do the updating required!!

have you tried manually updating to OS5 from your current firmware version?

No. That’s one solution I haven’t tried because of the warnings in bold and red and sounding so insistent on all the info pages including here:
https://support-en.wd.com/app/answers/detail/a_id/29813

" Before updating to My Cloud OS 5, your device must be updated to Firmware 2.41.121 or higher.

  • Download firmware version 2.41.121 for your My Cloud model from the WD Support Website to your local computer…"

I was hoping a tech support type individual would weigh in on whether that’s a safe bet. I fear the brick!

Hej hej,

i have the same problem… and working on it since weeks.
i tried everything but it already fails to upgrade the firmware necessary to upgrade to My Cloud OS5.
Why isn`t it possible to do all necessary things in the dashboard?
i have 2 Cloud Mirror Gen2

image

Same here. One of them successfully updated (and moved to cloud OS 5), the other is stuck on 2.14 and says there’s no update available.

It would be nice if WD actually answered, given that they one-sided are rendering the device useless if I don’t upgrade.