MY Cloud Mirror does not work after a firmware udpate attempt

Hi all,

I just tried to do an firmware update to the new OS 1.5 following the instructions given in the WD website (very ppor instructions BTW) and in the middle of the process I lost the connectivity to the device (I think it was re-starting).

But it never came back and all its lights started to blink red and blue.

After waiting for some time (wondering if it would ever come back to life) I decided to try to remove the power cable and put it back to cause a reboot.

The error persisted. It basically starts to boot, gives blue light to the first disk, than again to the second and after 1-2 seconds all the lights starts to blink red and blue again and the devide does not work.

I tried to disconnect and connect the drives again, to reboot with just one drive…but it simply does not work.

I cannot find any help in the WD support page and not even a note about what does it mean the blinking lights.

Anyone has experienced it before and can give me a guidance on how to fix the issue ?

Thank you,

I have the same issue. I get a message stating I should download and then upload firmware 1.01.00 which, of course, cannot be found. 

It also states: Your device firmware appears to be corrupted and your device is currently running in Safe Mode.


Donwload the latest firmware from WDC (1.05.21 in this case)

Extract the .bin file

Place that .bin file in the root of drive C:  <— It NEEDS to be in ROOT of C:

Start any browser

Put the address of the your drive in the address bar (e.g.

When the dialog box appears, select the .BIN file located in the C: root folder and click Apply.

You will see the file upload progress, and after a number of minutes, you will see the drive rebooting (lights on drive also change).

Drive reboots and everything is back to normal.

Hi ronfar,

Thank you for the answer.

Unfortunately it did not work for me as I’m unable to access the device either via the dashboard or direct via its address.

I simply do not know how to get access to it.

I sent an e-mail to WD support but got no answer yet.


Hi Mynotcloud,

How did you solve your issue as I updated my WD Cloud Mirror today and now there is no way to connect to it and the power led led blinking red and the two drive leds are  blue and blinking rapid red jaust above the blue?

I solved it my self, for some reason it didn’t help to write the ip adress into my browser or use the WD apps, but then I used the IP Scanner Home app and it found the MCM directly and from there it was an option to open it with the browser and  I was connected into safemode and reinstalled the firmware. Strange as it was the same adress I tried several times to copy and paste or write in manually???