Firmware problem

I decided to update my firmware from 2.xx to the latest one, but upon doing so it failed on the update. When I visit My Cloud’s IP address within IE, I get the new looked firmware, but it is very slow and won’t let me see anything about my drive. I can’t even see my Shares when I click on the link, yet it tells me I have 10 Shares on the home screen. Also, when I refresh webpage it freezes.

How can I resolve this problem, is there any way I can backtrack to factory firmware? I have tried holding reset for 30 seconds, unplug power and wait 30 seconds, then reconnect power and hold reset for 30 seconds but this has not done anything. I did this while continuing to hold reset.

Give the My Cloud some time to rescan the contents stored on the My Cloud and to settle down post upgrade. Sometimes it can take a hour or two for the My Cloud to settle down post firmware upgrade.

If after a couple of hours the My Cloud is still sluggish, try performing a 4 second reset and if that doesn’t work a 40 second system restore.

When you say ‘the latest one’, do you mean you tried to load a v4 firmware? If so, that won’t work: the v2 firmware is for ‘Gen 2’ devices, and is a separate development branch to the Gen1 v3/v4 firmware.

Whoever came up with this naming system is an eejit. Actually, whoever came up with the idea of multiple code bases for the MyCloud product line is an eejit. I’ve had to resort to vernacular Scots to avoid the censor…

It has been weeks since I tried to upgrade firmware, so it has had plenty of time to rescan contents. I have also tried a 4 second and 40 second reset and eventually after many attempts, I can access my shares but I cannot view settings via IP address of Cloud drive anymore.

Thank you for the info Bennor!! :slight_smile: