MyCloud 4.04.04-101 failed to update to 04.05.00-320

I bought the MyCloud years ago but never worked well. Always self rebooting all the time. Now, I am with 04.04.04-101 firmware. I tried to update it to 04.05.00-320 but always fail. I tried to do it from the dashboard. The dashboard could find new firmware, download it, then tried to update it but finally failed. I also downloaded the sq-040500-320-2071027.deb, then update it in dashboard with update from file option. It also failed.

Can someone tell me how to update to the new firmware so I have a chance to have a normal working MyCloud? Thanks

When you say it failed, what specific error message did the My Cloud Dashboard display to indicate a failure? Have you tried doing a 40 second reset then performing an update? Have you made any unofficial modifications to the MY Cloud firmware using SSH in the past?

Last month when I tried to use the MyCloud again, I did a 40 second reset. Then download bunch of photos to the MyCloud. I did not turn on the SSH. Somehow, my PC notified me that the MyCloud reset from time to time. I can still use the MyCloud. At the dashboard, I found that there was a newer version of firmware and tried many times to download it. Everything followed the firmware sequence and the notification showed firmware download, initialization, rebooting, etc. At the end, the firmware was still the 04.04.04-101, nothing change. Today, I did System Only System Factory Restore. Then update firmware but still failed. I did not see any specific error message.

Bennor,

[/uploads/default/original/3X/3/3/338bab40eebe08f9610541c5559db06e70fab02d.png]

Error Message
Timeout; waiting for firmware upgrade. Verify that the LED on the front of your device is not red; then find the device on the network and reinitialize the web user interface. If the LED is red, reboot your drive manually. (370008)

[/uploads/default/original/3X/5/5/55d490b2cafe0a9be3b7cb6240f711bf06ba17bb.png]

[/uploads/default/original/3X/5/1/5106044604bb2fa4fb3e8153d86914a923d1951f.png]

[/uploads/default/original/3X/e/c/ecc2d9dc65b94d420c829087a33fb5fe5e21e9cc.png]

[/uploads/default/original/3X/0/0/003024eaf21d681e7d3f56f266f45af2d55f51b3.png]

Image not loading.

Have you tried manually downloading the latest firmware from the My Cloud website and manually installing the file using the Dashboard > Settings > Firmware page?

ON being notified on your computer, that is generally due to having one or more WD programs installed which is contacting the My Cloud to display the alert/notifications that one can see by selecting the Alert/Notification icon (mycloudnotificationicon) in the My Cloud Dashboard.

One can delete those notifications in the My Cloud Dashboard.

I did manual firmware update. The error message was the result.

[/uploads/default/original/3X/0/c/0c247f4bd7afd15b4b10fece947645d54982aba6.png]

Image still not showing.

Couple of additional suggestions. Make sure the correct time is shown on the My Cloud Dashboard > Settings page. Disable Cloud Access as a troubleshooting step. Try setting the My Cloud to use a Static IP address on the Dashboard > Settings > Network page and use public DNS servers rather than your ISP DNS servers.

I send you all the screen capture through email.

Just checked, the dashboard time was identical to time shown on windows. I always use DHCP. I don’t know what DNS server to enter.

If I do a hard 40 second reset, will this erase all the photos and videos on the drive? Can I still recover them after hard reset?

No user data is deleted when performing a 40 second reset. See the following WD Knowledgebase article on what settings are reset to default values when performing a 4 second or 40 second reset.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13986