Firmware 4.05.00-315 Discussion


#1

New firmware released for the v4.x single bay My Clouds:
https://community.wd.com/t/new-release-my-cloud-firmware-versions-4-05-00-315-2-30-165-4-13-17/202232

Feel free to discuss good/bad below.

What’s new in Version 4.05.00-315!

Enhanced SMB server (samba) to support Apple Time Machine protocol extensions.
Enhanced SMB server (samba) to operate using SMB-3 protocol by default.
Resolved critical security vulnerabilities.
Improved MyCloud Cloud connectivity across MyCloud web, mobile & client apps.
Added analytics for network connection configuration.
Resolved issue where analytics logs were not updated as expected.

Release Notes: http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_04.05.00-315.pdf?v=183

Firmware Release 04.05.00-315 (04/12/2017) Link: http://download.wdc.com/nas/sq-040500-315-20170331.zip


WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links
Latest firmware still vulnerable
WD My Cloud randomly wakes up the drive when Drive Sleep is enabled
Firmware 2.30.165 Discussion
Did she sleep!
WD MYCloud always spinning
My Cloud won't standby
#2

I do like the way the WD announcement takes you to a download link for the last version, not the latest version…

Thanks for the working link.


#3

No problem. I too get the old firmware links now for some reason, don’t know if its my ISP caching the page or what. Worse when I click the firmware upgrade check link in the dashboard it said the firmware was up to date (ie no new firmware). Had to manually update to the latest version using the direct link above.

Manual upgrade went fine. So far no problems with the new firmware.


#4

Few more comments:
Twonky still at 7.2.9-6_7.5.0-77.
Get-SmbConnection indicates Samba 3 appears to be active on mapped Shares.
Main Public Share STILL cannot be disabled or set to Private.


#5

Mine shows firmware v04.04.05-101 so why is this a new release? I am confused.


#6

It looks like yet another premature release haa been pulled: the notice has dropped off the sticky thread list, and the ‘latest firmware’ link in the notice points to the December release.


#7

Which is the firmware I have loaded. And checking for update says its up to date.


#8

WD pulled the announcement they posted yesterday for both the first gen and second gen firmware. You can still see that announcement in the OP post (or in this link). For what ever reason WD pulled the announcement of both firmware’s 11 hours ago from this subforum and the announcements subforum.

WD did something similar with several other My Cloud model’s firmware a week or two ago. They released it, then pulled it and released a newer version a few days later. I can only assume they will do the same here.


#9

Samba Version 4.3.11 in version v04.05.00-315.
Not even close to current, still tons of bugs & security holes. WD also appears not to have updated the .conf file to account to deprecations.

edited to reflect firmware v04.05.00-315


#10

It is better than the current version 4.0.0.rc5 on gen1 and version 4.0.9 on Gen2.


#11

Not for me, at least. The rc5 version let my unit sleep; now, it’s waking up every 13 minutes and throwing an error message in log.smbd, IF it sleeps at all.

[2017/04/16 20:08:05.421299, 1] (serverid_rec_parse)
Found invalid key length 8 in serverid.tdb
[2017/04/16 20:21:06.201313, 1] (serverid_rec_parse)
Found invalid key length 8 in serverid.tdb
[2017/04/16 20:34:06.981360, 1] (serverid_rec_parse)
Found invalid key length 8 in serverid.tdb
[2017/04/16 20:47:07.761310, 1] (serverid_rec_parse)
Found invalid key length 8 in serverid.tdb


#12

Is this error something new with 04.05.05.113 firmware? Because I don’t see that error on 04.04.02-105.


#13

It must be due to v04.05.00-315. My debug, messages and samba logs are getting filled up, something which didn’t happen in prior versions.

I think we now know why WD pulled the firmware.

edited to reflect firmware v04.05.00-315


#14

Not seeing that error in 4.05.00-313 on my end in the log.smbd file. What I do see is a bunch of the following and nothing else:

[2017/04/09 15:11:55, 0] (smbd_main)
smbd version 4.0.0rc5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2012
[2017/04/10 08:29:42, 0] (smbd_main)
smbd version 4.0.0rc5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2012
[2017/04/11 01:35:37, 0] (smbd_main)
smbd version 4.0.0rc5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2012
[2017/04/11 19:49:31, 0] (smbd_main)
smbd version 4.0.0rc5 started.
Copyright Andrew Tridgell and the Samba Team 1992-2012
Strangely the last date is 4/11/17 even though I’ve rebooted/restarted the My Cloud since then.

I do have a startup script to deal with the sleep issue though. Seems to work fairly well at keeping the unit in sleep mode (for the most part) when not in use.

stop and disable indexing services (stop and disable service)

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
update-rc.d wdmcserverd disable
update-rc.d wdphotodbmergerd disable

stop RESTSDK server daemon

for OS3 only

/etc/rc2.d/S20restsdk-serverd stop

stop unwanted wakeups

mount -o remount,noatime,nodiratime /dev/root /


#15

v04.05.00-315 is using samba 4.3.11, and it’s all gone to hell.


#16

WD has once again released firmware 4.05.00-315 & 2.30.165 for the single bay My Clouds:

New Release - My Cloud Firmware Versions 4.05.00-315 & 2.30.165 (4/19/17)


#17

For some reason MyCloud has stopped sending me email notifications of link down or restart as it used to do about a month ago. I checked the notifications options and when I send test mail, I get that fine. Also I have set it to send all notifications to me. Any idea why this is happening? This has been happening even before the update. The update occurred ok. WDMyCloud v04.05.00-315 : Core F/W


#18

Yeah, I think I’ll wait and let someone else be the guinea pig this time. I reverted to v04.04.05-101, and I’m not upgrading again until someone else posts that the Samba disaster has been resolved.


#19

What Samba disaster? Been using 4.05.00-315 since 4/13 without any noticable problems on the local network with Windows 10.


#20

As described in my previous posts. Did not work for me at all.