Factory reset without dashboard?

I am having issues with my My Cloud device, and now the dashboard returns an internal server error.  I’ve already tried the reset options with the paperclip but no luck.  Is there a way to factory reset using ssh?


I have never tried a factory reset with SSH. Lets see if another user can share his experience. If the drive is not resetting with a paperclip try a power cycle and if the issue remains then I recommend you try contacting WD support.

Contact WD

Just be aware this is the MBL forum and not “my cloud” forum. Different devices…

I would first try to reboot if I were you… "

shutdown -r now

It seems there is a way for MBL device, however, it seems users got different results, if you want to preserve the data. This is one of them, search for the others on this forum.


what paperclip option? there is a 4 second and a 40 second.

to keep you data you don’t want to do a factory restore, you can do a system only restore which deletes users, resets password to default but leave all data and shares in tact. this can be done through the dashboard (if it was working) or with a the 40 second reset button option. for the 40 second option unplud the mycloud, press and hold the reset button while you connect the power to the mycloud, continue to hold for 40 seconds. Leave drive alone till you get a steady blue light in front

I’ve tried both the paperclip reset methods, but have not had any success.

The results so far:

  • I can access all my data, so have backed that up

  • The dashboard is still not working, I go to the IP for my cloud ( and get redirected to ( but it just shows a blank page.  Also the console in chrome shows a HTTP 500 error.

  • FTP and SSH have been disabled, so no longer have any access to any admin features

Am I now boned?

I’m having the exact same problem if anyone has any ideas

The same situation here.

Is there a way to deploy new firmware wihtout Dashboard and SSH?

if you still have remote access you can installit through the mycloud app although I am not sure how comfortable I would be with the other issues going on

you should be able to do a system only restore

WdMycloud app fails to connect to device.

The only services runing on device are Samba and FTP.

I don’t have any other access.

I have been reading on forum and I saw that system only restore does not help in most cases.

This error camed with firmware update.

I noticed that new firmware version solved this problem.

If developers know the problem I am sure they know the answer how to solve this issue.

in most cases where it is a mycloud issue the system only restore does fix the issue. this resets it to a like new configuration except leaves shares and data in place. All other setup needs to be re-done


I’ve got the same, what i did:

I’ve downgraded the os (debian) to the stable release.

This went quiet ok even after reboot.

After this, i’ve done some other stuff to which came out bad:

Don’t know if it was my bug or a bug in debian but i did this command after it:

apt-get autoremove.

Which removed everything from the test (current latest from wd).

So after this i tried to restore my actions with the debian firmware (sq-040101-413-20141106.deb).

The system was unable to restore itself due to the stable release.

After this my desktop computer became slow and had to restart the system which caused that i wasn’t able to connect with ssh to the nas.

After trying to reboot / reset the nas it isn’t reachable and the led indicates a constant white led. (no more blue).

I tried to reboot it with the reset button and even hold it longer than 40 seconds but the boot is probably **bleep**ed up and this didn’t do a thing.

I’ve tried it to connect directly to a laptop and tried the discovery software but it couldn’t detect the drive.

Now i’am having a few options left to try !

  • usb (which probably doesn’t work because the nas doesn’t boot correctly and i doubt it has bios support for usb.

  • remove the hardrive and put it in a computer and try to reinstall the drive for arm

    - there is also a nice arch-linux distribution available for arm which i might give a try

  • buy the exact same nas and do a diskcopy and i hope it will does its thing again and maybe return the product within 7 days.

Anyway i am a bit done with debian for the moment because i was trying to make a boot-usb of a wheezy distro (for amd-64) and this boot-usb caused my motherboard to fail after trying to boot from usb.

Is it by the way possible to boot from usb (on the nas) to get that thing working again ?

I’m having a similar issue. I really don’t want to do the system restore to rebuild the users… I did the 4 second reset and it reset the static IP to a DHCP one… I can SSH to the new IP no problem but the dashboard UI just goes blank after it displays “Accessing WD MyCloud, Attempting to Authenticate”.

It should not require a password popup screen but ot goes blank. So I have no control over the system. What else can I Do!!