Extremely slow ethernet connection

I recently posted about how I could only connect to my NAS via wifi only.
After doing several resets/static ip assignment I can connect to my NAS but it is really really slow.

Mounting a share on my desktop takes about 3min, but Im unable to save anything to/from the share as it takes so long and sometimes my finder crashes requiring a reboot.

It’s unusable at the moment and speaking to WD tech support on the phone offers no help either.

Im have two macs, 1 with Yosemite (10.10.5) and El Capitan (10.11.1) on another

Hello, what of router do you have? Are you using the finder or the WD My Cloud app?

Hi luna,
My router and set up are mentioned below. I should also say that I’ve tried both iMacs connecting to the NAS via cables and wifi and in both cases the cable method fails.

Router - TP-Link Archer D7 AC1750 (ADSL2+ dual band etc)
Power line - TP-Link TL-PA7020 KIT AV1000 (2 port gigabit etc)
Cat 6A cables - 10 metre & 1 metre
Have also tried Cat 5E cables similar lengths
Switch - Netgear GS608-400UKS gigabit (connected to the router but none of the above are connect to it)

Set up:
iMac 1 (El Capitan (10.11.1) connects via wifi - all good

iMac 2 (Yosemite (10.10.5) connects via ethernet (Cat 6A) > Power line > Router

EX2 (NAS with static IP) > Ethernet (Cat 6A) > Router

Firmware has been updated on both router and NAS.

Upgrading the NAS firmware to 2.11.133 has done nothing to speed up my connection to the NAS.

Im contemplating returning this…

Can anyone confirm a theory please, since WD Support are taking the mick in returning my emails.

Excuse my poor terminology, it’s 2:45am and Im knackered.

It seems like every time I connect to the NAS it’s trying to read all of the 100GB thats on it. (just a hunch)
My question is:

Is there a way to stop the process from happening everytime I connect/open folder?

I’ve uploaded a video showing just how unusable it is. Hope this video helps explain what I mean:

Looked at your video and I am wondering why are you using AFP for the file transfer? Apple has deprecated AFP in favor of SMB2 (which shows up as smb:// address in your video right at the beginning). Why don’t you try SMB aka Samba (on Linux) aka CIFS (on Windows). That’s aways been the standard for Windows and for several years has been the default fr Macs as well (since Mavericks), though AFP is still available as an option. Have you tried SMB and gotten similar results?

Hi Cybernut1,
Yes I’ve smb method - same results.

After spending around 2 hours with tech support, they blamed my power line adaptor for the fault. Basically they wanted to shift the problem away from them. I told them that I’ve tried two different branded power line adaptors and the problem persist Bad customer service!

I’ve tried different:
Power line adaptors

And the problem is still there. I asked for a replacement drive and have’t heard anything in 3/4 weeks.

I recently read somewhere that if you buy a diskless system (I bought a case and two drives separately) that they need to be formatted. I think I did this at the start but can’t be sure anymore. Question is will this make a difference? Especially when connecting to the drive is fine over the wifi network

the TP-Link Archer D7 AC1750 has a Bandwidth Control option which make you able to shape the wan traffic

it should not affect in LAN speed but sometimes it will shape and restrict LAN bandwidth speed in Wifi connected devices

please check this option in your TP-Link Archer D7 AC1750 web panel to be disabled

Hi David001,
If I understood your message right then you’re referring to the wifi network?
The problem Im experiencing is purely on ‘ethernet connection’ only.

And I went and checked the settings of the bandwidth control in the router and the default setting is ‘disabled’

Thanks anyway though!

Hello Cybernut1, I have a problem and Paulus say me to write you.

In my WD My EX2 app Joomla is out of date, it’s 2.5.26 version.
How upgrade it to latest Joomla version (3.5) ?
I don’t know how enter in My Cloud EX2 and upgrade manually app.
Thanks for your help.

Please don’t post off-topic questions in threads.

I replied to your Joomla thread few minutes ago with some info.

Hi NasDriver,

Hopefully you have already solved your problem, but if not… We recently purchased a new iMac (running El Capitan, whereas all the others are on Snow Leopard) at work and had disastrously slow connection speeds to all our servers (ReadyNAS Duo via AFP/SMB, Windows server, Mac server, etc.). It would take about 20 minutes to copy a 10 MB file. After weeks of despair we finally identified the problem as being our Netgear GS608 switch (which you also have). As soon as that was removed from the network, the iMac’s connection speeds matched our expectations. So, maybe try removing your switch (if you haven’t already) to see if that fixes your issue.


Hi Adam,
Thanks for your reply. I haven’t solved it yet and appreciate any advice/tips

I haven’t tried removing the switch form the network yet. It’s a good call and will try it! I didn’t remove it before because the EX2 is connected to the router and didn’t think it was worth doing but your post gives me some confidence

Thanks again