Slow copying files to NAS

All,

I am having a problem copying files to the NAS. I will detail my setup, the issue I have and the testing I have done so far.

SETUP:
Mac Laptop on wifi connection. SMB mapped drive to a share folder on the NAS
Mac Mini on a wired connection to the router. SMB mapped drive a share folder to the NAS
Netgear Nighthawk AC Router
WD EX 4 wired connection to the router. 4x 6TB Drives in RAID 5.

ISSUE:
This NAS is about a year and a half old. For many months I have noticed that copying files to the EX4 is very slow. I can copy a single 3.5 GB file from the Mac to the Mac Mini and the transfer speed is about 45MB/sec. This is what I would expect copying to the NAS. However, when I copy to the NAS I am getting transfer speed of 4-5MB/sec. This is literally 10X slower than it should be. I need help troubleshooting this issue.

TROUBLESHOOTING SO FAR:

  • I have verified all the connections at 1GBit/sec. Using Network Utility on the Macs and with the solid green light on the NAS as well as the white connection light on the router to all wired devices.)
  • I can copy the large file from the Mac to the Mac Mini at full speeds. This shows me the wifi connection is not the problem.
  • I have tried copying from the Mini to the NAS. The same slowness issue occurs even though both devices are hard wired to the router with a 1Gbit/sec connection.
  • I have tried a new cable between the router and the NAS
  • I changed the port the cable was connected to on the NAS
  • I have rebooted the NAS
  • I have updated to the latest firmware on the NAS
  • I have gone into the NAS and disabled nearly every service/application that could be using CPU or Memory. CPU is running ~8% now. I have left only Time Machine backups enabled. I have verified no backups were running during the transfer test.
  • Cloud Access, ITunes, DNLA, all are disabled
  • All 4 drives show as Healthy

WHATS NEXT???

Help!!! I have no idea what to do next except to start looking for a new NAS.

I’ve got nothing sorry. You’ve covered all the thing’s I can think of. I can get just under 100MB/s (write speed limited by the RAID5 array) on my hard wired 1GB network. Might be time to contact WD support.

Oh my mistake. I assumed support participated in these forums. Is that not the case?

Well the WD support ticket site is broken.

Fill out the form with all the details, click submit. Get an error that I need to enter a valid model number.

THERE IS NOT A MODEL NUMBER FIELD ON THE PAGE!!!

You could try calling them: http://support.wdc.com/contact.aspx?lang=en

I ran into that same form. Same problem. Drove me nuts.
After hours I figured out I needed to register the device first and from there I could select somewhere the option to contact WD. Aaaaaaaarch…

@Tritian

DOn’t know if you are still having issues or monitoring this post, but if you are:

You NEED to know if you have your router setup properly first and foremost. You say you have an AC router, so I assume it is a gigabit router. You also have two wireless bands at 2.4G and 5G. So, I hope you have router setup to see them both and not just one combined single signal. You need to see MyRouter_2.4G and MyRouter_5G and ALWAYS be connected to 5G and never 2.4G except for slow devices. Even so, you need your router to ONLY use the N-mode of your router (and not a combo of N, G or even B. Your wireless router will NOT work at its fastest wireless speed if you router is set up this way (and most are out of the box unless you adjust a setting in it to work on N-only.}

You also did a lot of unnecessary tweaks to your system, IMO.

Do you have a network switch either the computers or NAS are connected to? This could help if they both are connected to the same gigabit switch.

No one will ever get the speeds they expect if if they have not fully set up the router beyond the out of box condition.

I use my EX4 in a Mac environment and found the following:
AFP transfers are a bit faster than SMB.
If you don’t need cloud access, turn it off. I have cloud access disabled which improved responsiveness and transfers speeds considerably.
If you don’t use the NAS as a DNLP server, disable media streaming. I tested this and noticed a small improvement.
I noticed no real difference disabling iTunes.
If you have any other apps running like Dropbox, check the configuration. IIRC Dropbox was initially configured to update every 5 minutes. I changed my configuration to every hour.

During folder uploads I routinely see 18 to 30 MB/sec upload speeds. When transferring a single large file I have seen transfers speeds upwards of 80 MB/sec.

Apple Filing Protocol (AFP) is being deprecated in favor of Server Message Block version 2 (SMB2).

AFP Depreciated

For you, me, them, those, us, we & WD… best get to ground on SMB Performance that is on par with performance that AFP previously delivered.

here’s the result of moving a file on 3 different protocols. AFP is by far the fastest.
This is on EX2

Big Question - is the encryption enabled?

This was the fix. https://dpron.com/os-x-10-11-5-slow-smb/