Expanding Capacity on EX2 with Raid 1

Hi all,

I have an EX2 with 2x2TB drives that are set as Raid 1. Now, I am planning to upgrade these guys with 2x6TB. Is it possible to replace them 1 by 1 to avoid having to move the current data somewhere else and move it back into the new drives? I saw the “expand capacity” option under Raid1 configuration, but I cannot find any other document on how it works. Please advise, thanks!

1 Like

It is better to backup your data then put the two new hard drive and build a RAID 1 then copy back you data. It is better that way.

Thanks for the advise. I did make a backup. Then, I got curious and wanted to try the “expand capacity” option. Turns out it’s working right. I’m currently expanding my storage without having to lose any data from the current partition

Yes, the expansion is very easy. All you have to do is going through the question, then insert the hard drive one at a time when it tell you to.

insert the both new drive in the NAS and create the new RAID1. When i’ts finished replace 1 drive with the old one, he should rebuild the data. At the end re-insert the new drive. Done

I am trying to do the same expansion on the EX2 with RAID1 setup. Will the suggested way by Simone_Z work or will all the settings be lost?
Thanks for suggestions
T.

@andrep182 where can I find the “expand capacity” option in the menu you are mentioning?

@Thorsten_M I did not try Simone’s suggestion as my method worked just fine for me.

I found expand capacity from the following:

  • get to My Cloud main menu
  • click on ‘storage’
  • Under ‘Raid’ tab by ‘RAID Volume’, pick ‘Change RAID Mode’
  • It’ll warn you that it’ll interrupt the current services. Press ‘continue’
  • Pick RAID 1 and you should see ‘Expand Capacity’ option

It will then prompt you to remove and replace one of the drives. Once replaced, it’ll start copying data, then prompt you to switch the next one once it’s done.

Of course, I would suggest that you make another backup JUST IN CASE things go south prior to performing this expansion. Otherwise, it should be a piece of cake.

3 Likes

This was awesome. It may be 3 years old but it was exactly what I was looking for. I didn’t worry about a backup, I figured that I could use the first raid 1 drive I pulled out could be used to restore my data if needed. However, the process worked as advertised and I have all my data with additional capacity. (I upgraded from 2TB of available Raid 1 space to 4TB of space. (using 2 ea 4TB WD Red Drives)

1 Like

If it able to support 8TB drives, you will be very happy when drive price is cheap.

Hi,
I have 2TB+2TB WD Mycloud mirror gen2, one of the drives crashed, so I got myself 2 6TB drives, I replaced the spoilt 2 TB disk with the 6TB one and raid worked perfectly, it showed the capacity of the NAS as 2 TB, now I have replaced the other 2 TB hard drive with the second 6TB one, the RAID worked fine, but the capacity of the NAS still shows 2 TB, I don’t have any data on it as I have backed it up on another disk, I formatted the drive, even tried to extend the capacity but nothing happens, the capacity remains at 2 TB, what am I doing wrong?

1 Like

I’m having this exact problem. Let me know if you figure it out, I’ll keep searching too.

Didn’t work for me - whenever I try to do RAID 1 it warns me it will erase everything on the disks. What I have done is the following:

Both drives were 4TB.
I bought two new 5 TB disks.

I took out one 4TB disk and replaced it with one 5 TB disk.
When going to the CHANGE RAID mode button - and then selecting RAID 1 (and the Raid 1 checkbox) it WARNS me that it will erase the RAID and start anew. It does show the drive is 5 TB. Instead I did a manual rebuild.

After the rebuild completed, I took out the other 4 TB drive and put in a 5 TB drive. I attempted again to CHANGE RAID MODE and click Raid 1 and clicked the Raid 1 checkbox - but it showed same warning - that it will erase everything. Again - I did the manual rebuild - which is in progress now.

I hope that when this is done that I can do Change Raid Mode again - and now it will magically allow me to change capacity since both drives have only a 4 TB partition on a 5 TB disk. I’m on the new OS 5 - so I hope they kept this feature.

I’ll write back with my findings. I think there is a way in ssh to expand the raid volume - need to dig out my old docs. If anyone has any details on that I’d love to hear. Thanks!

OMG it worked! After the second disk was put in and the RAID1 was rebuilt - now I see EXPAND CAPACITY. The device is currently working on this - should be done in the next few hours. So in short - expand capacity won’t be present until both disks are replaced with larger disks. Only issue is that it is rebuilding the second disk again. It would have been better if I could replace one drive first and then expand it without RAID 1 then put in the second drive and rebuild the second drive once. The Expand Capacity didn’t show up with one drive in the device.

Actually it didn’t work. After it did the expansion I had the exact amount of space left. I am going to do a factory reset now. Hopefully this will use the entire space.

Hi all, I’ve the same issue when expanded 4Tb hdd with 8TB hdd. After wating 4 hours for the expand capacity, in the end, the capacity show is still 4TB… How this can be fixed? Any solution?
Thanks, regards!
Marco

Hi all,

Maybe I discovered what’s wrong: when in the expand capacity menu, you have to click next on various notifications. One of these is showing a status bar with curren size enhanced in BLUE. What is needed now is to click on this blue indicator that is a slidebar and move from old size to new size. And the waiting for the resizing. The error I did in the past was not to slide because I thought it was just an indication of current status and not ad active page. I suggest WD to better design that page or tho write in there “select the final size”. I’m doing the expansion right now, finger crossed!
Regards,
Marco

2 Likes

Marco40 is correct regarding the sliding blue bar. I have an PR2100 that had 2 4TB drives in RAID1 mode (original WD “RED” drives). One drive failed, so I bought 2 8TB GOLD drives. I replaced the bad 4BG drive with one of the new 8TB drives. From the web console, I turned on auto-rebuild (for some reason it was off), and the new drive started rebuilding the RAID1 with the data from the good working drive. After that finished, I pulled the original good 4TB drive and installed the 2nd new 8TB drive. That new drive then began to rebuild the RAID1 volume. All the original RAID1 data was retained and no data lost. I did not power down the PR2100 during any of this and just hot-swapped the drives. After the 2nd 8TB drive was rebuilt, I selected “Change RAID mode”, then selected “RAID1” (which is what the volume currently was). An “Expand Volume” option was presented (at some point, it asked if I wanted to insert a new drive and I selected “No” since the two new drives were already inserted and had the original RAID1 volume data on them). The “blue bar” with the slider control was presented and I slide it to the far right and started the expansion. Everything worked perfect and the RAID1 volume is now expanding from 4TB to 8TB with no data loss from the original RAID1 data on the 4TB drives.

NICE!!!

1 Like

A few additional notes. The expansion happens one drive at a time. I was able to still access all my data files during this time period. The 4TB RAID1 volume was almost completely full and the expansion looks like it takes a little over 5 hours per drive (10+ hours total) to extend the 4TB volume to 8TB (the GOLD drives are 7200 RPM so quite a bit faster than the old “RED” (not RED Pro)) drives. Backups run faster (5 PC’s running Acronis True Image once a day). Large file transfers between Dropbox and the PR2100 are noticeably faster. I’m also running the PR2100 with dual 1Gb connections to the router (an ASUS RT AX-88U) with 300Mb Internet service. I’ll keep the one working 4TB RED drive and put in my safe as another backup in the short-term. I’ll return the bad drive using WD’s free, secure, audited drive recycling service rather than figuring out how to destroy the device myself.

Thanks, I was having this issue as well and then read your comment.
This is a rather unintuitive method of expanding capacity. WD should have some some text around what should be done here.

1 Like